To celebrate the release of GATK 4.0, we are giving away free credits for running the GATK4 Best Practices pipelines in FireCloud, our secure online analysis portal. It’s first come first serve, so sign up now to claim your free credits worth $250. Sponsored by Google Cloud. Learn more at https://software.broadinstitute.org/firecloud/documentation/freecredits

Error running Cromwell 27-SNAP (build from master)

kcibulkcibul Cambridge, MAMember, Broadie, Dev
edited April 2017 in Ask the WDL team

I just started a Cromwell server running against a database used with Cromwell 25 and upon startup, I get the following errors:

[ERROR] [04/19/2017 18:14:32.636] [cromwell-system-akka.actor.default-dispatcher-4] [akka://cromwell-system/user/cromwell-service/ServiceRegistryActor/MetadataService] Error summarizing metadata
com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '"SUMMARY_STATUS_ENTRY" where ("SUMMARY_TABLE_NAME" = 'WORKFLOW_METADATA_SUMMARY_' at line 1

Best Answer

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Have you tried turning it off and on again?

  • kcibulkcibul Cambridge, MAMember, Broadie, Dev

    repeatedly ;) @ChrisL knows the answer

  • alphahmedalphahmed JAPANMember

    Using Cromwell 29, just for a basic regular GATK workflow, I keep getting very similar error at the recalibration step ("BaseRecalibrator" walker of GATK 3.8).

    [2017-11-27 16:44:21,60] [error] Failed to summarize metadata
    java.sql.SQLTransientConnectionException: db - Connection is not available, request timed out after 8544ms.
    at com.zaxxer.hikari.pool.HikariPool.createTimeoutException(HikariPool.java:548)
    at com.zaxxer.hikari.pool.HikariPool.getConnection(HikariPool.java:186)
    at com.zaxxer.hikari.pool.HikariPool.getConnection(HikariPool.java:145)
    at com.zaxxer.hikari.HikariDataSource.getConnection(HikariDataSource.java:83)
    at slick.jdbc.hikaricp.HikariCPJdbcDataSource.createConnection(HikariCPJdbcDataSource.scala:18)
    at slick.jdbc.JdbcBackend$BaseSession.(JdbcBackend.scala:439)
    at slick.jdbc.JdbcBackend$DatabaseDef.createSession(JdbcBackend.scala:47)
    at slick.jdbc.JdbcBackend$DatabaseDef.createSession(JdbcBackend.scala:38)
    at slick.basic.BasicBackend$DatabaseDef.acquireSession(BasicBackend.scala:218)
    at slick.basic.BasicBackend$DatabaseDef.acquireSession$(BasicBackend.scala:217)
    at slick.jdbc.JdbcBackend$DatabaseDef.acquireSession(JdbcBackend.scala:38)
    at slick.basic.BasicBackend$DatabaseDef$$anon$2.run(BasicBackend.scala:239)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
    at java.lang.Thread.run(Thread.java:748)

    The only linked database to this run is the "knownSites" vcf file, which seems to be already loaded into the inputs directory of cromwell-excusions for each sample.

  • EADGEADG KielMember

    Hi @alphahmed .

    the database which is meant in your error is the database from cromwell, running on default options, cromwell creates an in-memory database. Did you try to run cromwell with a decided database?

    The second, did you check the load on your server? I get a similar error when the server runs on extremely high loads and the DB is to slow to answer at an adequate amount of time.

    Greetings EADG

  • alphahmedalphahmed JAPANMember

    Thanks EADG!
    No I didn't assign a database to cromwell upon running it.
    You're explanation on the second one makes a lot of sense, I am applying an extreme load on the server, which is very likely the cause of both errors.

    I appreciate it!

  • ChrisLChrisL Cambridge, MAMember, Broadie, Moderator, Dev

    Just a side note on this, for whatever reason the default in-memory database seems to scale significantly worse than a regular MySQL instance, so don't give up hope until you've tried the same scale test backed by a MySQL DB!

Sign In or Register to comment.