To celebrate the release of GATK 4.0, we are giving away free credits for running the GATK4 Best Practices pipelines in FireCloud, our secure online analysis portal. It’s first come first serve, so sign up now to claim your free credits worth $250. Sponsored by Google Cloud. Learn more at https://software.broadinstitute.org/firecloud/documentation/freecredits

batch endpoint

conradLconradL BrisbaneMember

Hi;
I'm testing out the REST API with cromwell running in server mode and can hit the regular workflow submission just fine, e.g. with curl:

[conradL@slithytove ~]$ curl -v "http://localhost:8000/api/workflows/v1" -F >wdlSource=@batch.wdl -F workflowInputs=@one.inputs

  • Trying 127.0.0.1...
  • Connected to localhost (127.0.0.1) port 8000 (#0)
  • Initializing NSS with certpath: sql:/etc/pki/nssdb

    POST /api/workflows/v1 HTTP/1.1
    Host: localhost:8000
    User-Agent: curl/7.43.0
    Accept: /
    Content-Length: 766
    Expect: 100-continue
    Content-Type: multipart/form-data; boundary=------------------------8327a524179cc23f

    < HTTP/1.1 100 Continue
    < HTTP/1.1 201 Created
    < Server: spray-can/1.3.2
    < Date: Sun, 15 May 2016 07:33:36 GMT
    < Content-Type: application/json; charset=UTF-8
    < Content-Length: 75
    <
    {
    "id": "c218bd0d-bfed-4f65-96ae-ee6eb3773732",
    "status": "Submitted"

  • Connection #0 to host localhost left intact
    }

but when I try to hit the batch endpoint documented on github here I get an HTTP error:

[conradL@slithytove ~]$ curl -v "http://localhost:8000/api/workflows/v1/batch" -F >wdlSource=@batch.wdl -F workflowInputs=@batch.inputs

  • Trying 127.0.0.1...
  • Connected to localhost (127.0.0.1) port 8000 (#0)
  • Initializing NSS with certpath: sql:/etc/pki/nssdb

    POST /api/workflows/v1/batch HTTP/1.1
    Host: localhost:8000
    User-Agent: curl/7.43.0
    Accept: /
    Content-Length: 905
    Expect: 100-continue
    Content-Type: multipart/form-data; boundary=------------------------>a2cc77bb03147aa5

    < HTTP/1.1 100 Continue
    < HTTP/1.1 405 Method Not Allowed
    < Server: spray-can/1.3.2
    < Date: Sun, 15 May 2016 07:34:14 GMT
    < Allow: GET, OPTIONS
    < Content-Type: text/plain; charset=UTF-8
    < Content-Length: 56

  • HTTP error before end of send, stop sending
    <

  • Closing connection 0
    HTTP method not allowed, supported methods: GET, OPTIONS`

I have checked that the form of the URL is exactly as suggested in the docs, i.e.:

http://host:port/api/workflows/:version/batch

I'm running with version 0.18

Tagged:

Best Answer

Answers

Sign In or Register to comment.