Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Update: July 26, 2019
This section of the forum is now closed; we are working on a new support model for WDL that we will share here shortly. For Cromwell-specific issues, see the Cromwell docs and post questions on Github.

Switching backends without making "local" tasks non-local

According to multiple posts here, we're supposed to be able to do this to specify that a task should run locally:

runtime {
  backend: "Local"
}

Cromwell does appear to be using this over whatever the default in the application.conf file is, however, if I try to tell Cromwell to use a backend other than the default in my workflow options, it gets applied to all tasks, including the ones that are supposed to run locally. Moving the backend setting to default_runtime_attributes is ignored. Am I missing the point of what backend: "Local" actually does or is there a bug here?

Sign In or Register to comment.