Editing a configuration file doesn't work

I am working in an environment with limited privileges, and I must call Docker with sudo and root user. I have tried testing Docker use with your basic hello world example, but adding a Docker image:

task hello {
  String name

  command {
    echo 'Hello ${name}!' > test.out
  }
  runtime {
    docker: "sime_image:0.1"
    docker_user: "root"
  }
  output {
    File response = "test.out"
  }
}

workflow test {
  call hello
}

I downloaded your config file, added sudo under at the beginning of submit-docker command, and called Cromwell with this statement:

java -Dconfig.file=config.conf -jar cromwell-35.jar run test.wdl --inputs inputs.json

It behaves like it doesn't see the change. Even writing something random in that field still return no permission to run docker error. Whatever change I make in the config the error is unchanged.

What am I doing wrong?
Also, is this the correct method to modify docker command?

Answers

  • RuchiRuchi Member, Broadie, Moderator, Dev admin

    Hey @OggieM,

    Would you mind sharing your config? Conceptually, what you're doing should just work. The fact that adding in random stuff in the field returns the same error tells me the changes aren't being picked up, so I'd like to confirm that the changes are being made in the right place in the config.

    Thanks

  • OggieMOggieM Member

    This is an example where I just copied the submit command. The content of stderr file is:

    docker: Got permission denied while trying to connect to the Docker daemon socket at connect: permission denied.
    See 'docker run --help'.
    "docker wait" requires at least 1 argument.
    See 'docker wait --help'.
    
    Usage:  docker wait CONTAINER [CONTAINER...]
    
    Block until one or more containers stop, then print their exit codes
    "docker rm" requires at least 1 argument.
    See 'docker rm --help'.
    
    Usage:  docker rm [OPTIONS] CONTAINER [CONTAINER...] [flags]
    
    Remove one or more containers
    

    This tells me that it didn't take the command.
    Thanks in advance!

  • OggieMOggieM Member

    Btw, the forum interprets unix paths as links, and since I am a noob, it won't let me do that. I erased them from the stderr printout.

Sign In or Register to comment.