Reference Genome ERROR

INFO 18:34:12,982 HelpFormatter - --------------------------------------------------------------------------------
INFO 18:34:12,984 HelpFormatter - The Genome Analysis Toolkit (GATK) v3.7-0-gcfedb67, Compiled 2016/12/12 11:21:18
INFO 18:34:12,985 HelpFormatter - Copyright (c) 2010-2016 The Broad Institute
INFO 18:34:12,985 HelpFormatter - For support and documentation go to https://software.broadinstitute.org/gatk
INFO 18:34:12,985 HelpFormatter - [Tue Jul 03 18:34:12 CST 2018] Executing on Mac OS X 10.13.5 x86_64
INFO 18:34:12,985 HelpFormatter - Java HotSpot(TM) 64-Bit Server VM 1.8.0_171-b11
INFO 18:34:12,988 HelpFormatter - Program Args: -T HaplotypeCaller -R GCF_000001405.25_GRCh37.p13_genomic.fna.fai -I dedup_reads.bam -o raw_variants.vcf
INFO 18:34:13,177 HelpFormatter - Executing as [email protected] on Mac OS X 10.13.5 x86_64; Java HotSpot(TM) 64-Bit Server VM 1.8.0_171-b11.
INFO 18:34:13,177 HelpFormatter - Date/Time: 2018/07/03 18:34:12
INFO 18:34:13,177 HelpFormatter - --------------------------------------------------------------------------------
INFO 18:34:13,177 HelpFormatter - --------------------------------------------------------------------------------
INFO 18:34:13,188 GenomeAnalysisEngine - Strictness is SILENT

ERROR ------------------------------------------------------------------------------------------
ERROR A USER ERROR has occurred (version 3.7-0-gcfedb67):
ERROR
ERROR This means that one or more arguments or inputs in your command are incorrect.
ERROR The error message below tells you what is the problem.
ERROR
ERROR If the problem is an invalid argument, please check the online documentation guide
ERROR (or rerun your command with --help) to view allowable command-line arguments for this tool.
ERROR
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions https://software.broadinstitute.org/gatk
ERROR
ERROR Please do NOT post this error to the GATK forum unless you have really tried to fix it yourself.
ERROR
ERROR MESSAGE: Fasta index file /Users/siddharth/Documents/Hemant_backup/001_promoter_project/Rerun_samples/Variant_testrun/GCF_000001405.25_GRCh37.p13_genomic.fna.fai.fai for reference /Users/siddharth/Documents/Hemant_backup/001_promoter_project/Rerun_samples/Variant_testrun/GCF_000001405.25_GRCh37.p13_genomic.fna.fai does not exist. Please see https://software.broadinstitute.org/gatk/documentation/article?id=1601 for help creating it.
ERROR ------------------------------------------------------------------------------------------

Answers

  • ChrisLChrisL Cambridge, MAMember, Broadie, Moderator, Dev ✭✭

    Hi @srs1402 -

    The index file is missing because you need to localize the index file to the working directory along with the reference.

    We usually recommend declaring an index file variable in the inputs section of the task. Same goes for the reference dictionary file (.dict).

    Even though you don't use them in the command section, the files will be localized next to each other so that the GATK command can find them when it needs them.

  • fmladfmlad Member

    Hello,
    I am running the HaplotypeCaller command in gatk4. I have the .dict and .fai files in the same directory as my .fasta reference genome file but I still get the error 'A USER ERROR has occurred: Fasta index file file:/REFERENCE/path/to/ref.fasta.fai for reference file:/REFERENCE/path/to/ref.fasta does not exist'.
    I have created the dictionary file with the CreateReferenceDictionary in Picard and the .fai file was created using samtools faidx. Please any suggestions?

Sign In or Register to comment.