To celebrate the release of GATK 4.0, we are giving away free credits for running the GATK4 Best Practices pipelines in FireCloud, our secure online analysis portal. It’s first come first serve, so sign up now to claim your free credits worth $250. Sponsored by Google Cloud. Learn more at

workflow options

I'm trying to specify the root folder where the cromwell analysis is run using the --options flag for cromwell. According to the docs, I should just mimic the structure of the cromwell config file, but I cannot get it to work.

Workflow options:

$ cat workflow_options.json 
  "backend": {
    "providers": {
      "LocalExample": {
        "config": {
          "root": "/data/Hex/cromwell-executions"
  "final_workflow_outputs_dir": "/data/Hex",
  "workflow-log-dir": "/data/Hex/cromwell-workflow-logs"

Error message:
[2018-01-18 10:45:32,92] [warn] SingleWorkflowRunnerActor: received unexpected message: WorkflowSubmitFailed(java.lang.RuntimeException: Unsupported key/value pair in WorkflowOptions: backend -> {"providers":{"LocalExample":{"config":{"root":"/data/Hex/cromwell-executions"}}}}) in state SubmittedSwraData $? is -15

Best Answer


Sign In or Register to comment.