Update: July 26, 2019
This section of the forum is no longer actively monitored. We are working on a support migration plan that we will share here shortly. Apologies for this inconvenience.

task in workflow hangs at 0%

I have created a workflow that includes base quality score recalibration with lacer ( https://github.com/swainechen/lacer). However, when I run the workflow, the lacer process keeps running forever, continiously printing out the status message that it is at 0%.


For all read groups: 0/0 (calibration/total) bases processed [Mon Aug 14 07:26:22 2017] Pileups: 0% [Mon Aug 14 07:26:27 2017] Pileups: 0%

I know that sounds like a problem with lacer. However, when I manually run the script.submit script that cromwell generates, it runs fine and completes successfully.

call-lacer/shard-0/execution$ ./script.submit 
Subroutine PDL::CLONE_SKIP redefined at /usr/local/lib/x86_64-linux-gnu/perl/5.22.1/PDL/Parallel/threads.pm line 39, <DATA> line 207.
# Start time: 1502695692
# Original command line: /usr/local/bin/lacer.pl -bam /cromwell-executions/variantDiscovery/92b86ee8-c622-4176-ad27-f43f69020664/call-lacer/shard-0/inputs/data/test/cromwell-executions/variantDiscovery/92b86ee8-c622-4176-ad27-f43f69020664/call-dedup/shard-0/execution/102517-22.dedup.bam -reference /cromwell-executions/variantDiscovery/92b86ee8-c622-4176-ad27-f43f69020664/call-lacer/shard-0/inputs/data/test/cromwell-executions/variantDiscovery/92b86ee8-c622-4176-ad27-f43f69020664/call-reference/execution/NC_011083.fasta -outfile 102517-22_recal.txt -verbose 2
# windowsize (for pileups): 10000
# SVD binsize (for quality histograms): 3000
# Maxcov 0, Min mapping 30, Min base 6
# vcf mode 0
[Mon Aug 14 07:28:13 2017] Pileups:   0%

Lacer version 0.42 running on /cromwell-executions/variantDiscovery/92b86ee8-c622-4176-ad27-f43f69020664/call-lacer/shard-0/inputs/data/test/cromwell-executions/variantDiscovery/92b86ee8-c622-4176-ad27-f43f69020664/call-dedup/shard-0/execution/102517-22.dedup.bam

For all read groups: 8824/14410244 (calibration/total) bases processed
[Mon Aug 14 07:31:08 2017] Pileups:   1%

What can I do to figure out what is going on here, why does it get stuck at 0% when I run it with cromwell, but not when I run script.submit manually?

Answers

Sign In or Register to comment.