Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

DepthOfCoverage multi-threading

tommycarstensentommycarstensen ✭✭✭United KingdomMember ✭✭✭

Does the walker DepthOfCoverage support multi-threading?

According to the documentation:
http://www.broadinstitute.org/gatk/gatkdocs/org_broadinstitute_sting_gatk_walkers_coverage_DepthOfCoverage.html
"This tool can be run in multi-threaded mode using this option. TreeReducible (-nt)"

When I try with GATK2.5 I get this error message:
"Invalid command line: Argument nt has a bad value: The analysis DepthOfCoverage aggregates results by interval. Due to a current limitation of the GATK, analyses of this type do not currently support parallel execution. Please run your analysis without the -nt option."

Would it work, if I upgraded to 2.7? You upgrade GATK more frequently than I change my under wear, so it is difficult to keep up :) Thanks!

Tagged:

Best Answer

  • Geraldine_VdAuweraGeraldine_VdAuwera admin Cambridge, MA admin
    Accepted Answer

    Hi Tommy,

    If you don't mind I'll refrain from commenting on your personal hygiene and sartorial habits :)

    But as regards to the issue you're running into: it's not really a version problem. What's happening here is that by default the DoC is set to generate stats averaged over intervals, which is not compatible with multithreading mode. If you pass the --omitIntervalStatistics / -omitIntervals flag this will be disabled and multithreading ability will be restored. We'll look at documenting and/or putting in a workaround to avoid this situation in the future.

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera admin Cambridge, MAMember, Administrator, Broadie admin
    Accepted Answer

    Hi Tommy,

    If you don't mind I'll refrain from commenting on your personal hygiene and sartorial habits :)

    But as regards to the issue you're running into: it's not really a version problem. What's happening here is that by default the DoC is set to generate stats averaged over intervals, which is not compatible with multithreading mode. If you pass the --omitIntervalStatistics / -omitIntervals flag this will be disabled and multithreading ability will be restored. We'll look at documenting and/or putting in a workaround to avoid this situation in the future.

  • tommycarstensentommycarstensen ✭✭✭ United KingdomMember ✭✭✭

    Thank you! I actually prefer getting an error message instead of occupying multiple processors for a single core job.

Sign In or Register to comment.