Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Why is BaseRecalibrator so slow - not using all threads?

Hi,

I'm running BaseRecalibrator on a full lane of HiSeq. I set the -nct switch to 8, but I see that the average load is <1. Why is this so? Doesn't the BaseRecalibrator use threads properly?

I've seen this thread http://gatkforums.broadinstitute.org/discussion/1263/baserecalibrator-trade-off-between-runtime-and-accuracy on how to speed up the process by downsampling. Is this a better option considering I have >200M reads?

BTW I'm using version 2.2-8 - do newer versions implement -num_threads?

I would really love to reduce the runtime from 36hrs.

Many thanks.

Answers

  • drchriscoledrchriscole Member

    After a bit of investigating of parameters I've used the -dfrac 0.05 and -dt ALL_READS options to get my runtime down to ~3hrs.

    However, the low amount of CPU load is still a concern.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    You should definitely use the latest version to take advantage of recent improvements that have been made at many levels of the GATK -- such as the revamped downsampling engine which is less biased than the previous implementation.

    BaseRecalibrator does not support the use of data threads (-nt), only cpu threads (-nct) which you're already using. I can't say why you would see a smaller cpu load than expected; the tool itself uses cpu threads just fine in our hands. Some people have platform or filesystem-related issues getting multithreading to work properly, but that's not something we can do anything about at the moment.

  • Mark_DePristoMark_DePristo Broad InstituteMember admin

    Definitely use the latest GATK. But it's possible that your system's IO cannot handle the input / output requirements in some way, as you can quickly bottleneck on getting the data or writing it out for 8x throughout. Does the problem persist with the lastest GATK and with a local BAM file?

  • drchriscoledrchriscole Member

    Thanks for the replies.

    I've monitored the process with top and I can't see any I/O waiting - it flicks between running and idling - but that might be too blunt a tool?

    I'll try a newer version and see how things progress.

Sign In or Register to comment.