Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Mutect2 dont-use-soft-clipped-bases doesn't work properly

Hi guys,

I'm using Mutect2 from gatk version 4.1.2.0. to perform variant calling in tumor samples.
Since I'm using amplicon data I have clipped small portion of sequences at both end from the alignment before the variant calling.
Using Mutect2 with the option "--dont-use-soft-clipped-bases true" for the majority of the variants the depth is counted correctly.
However I get variants that is still counted as if it was not clipped.
I attach an example:

what I get without the --dont-use-soft-clipped-bases true option:
17 31235687 31235687 C A 17 31235687 . C A . . DP=61;ECNT=2;MBQ=39,39;MFRL=186,187;MMQ=36,33;MPOS=32;POPAF=7.30;TLOD=34.49 GT:AD:AF:DP:F1R2:F2R1:SB 0/1:48,13:0.222:61:14,13:34,0:34,14,0,13

what I get with the --dont-use-soft-clipped-bases true option:
17 31235687 31235687 C A 17 31235687 . C A . . DP=61;ECNT=2;MBQ=39,39;MFRL=186,187;MMQ=36,33;MPOS=32;POPAF=7.30;TLOD=34.49 GT:AD:AF:DP:F1R2:F2R1:SB 0/1:48,13:0.222:61:14,13:34,0:34,14,0,13

The total depth without considering the clipped reads should be 27 (14ref and 13 alt) but I still get 61, is there something that I can do to adjust the depth count?

Thanks for considering my request

'''
java -Xmx2g -jar /opt/gatk-4.1.2.0/gatk-package-4.1.2.0-local.jar Mutect2 --reference /data/REFERENCES/Genomes/hg38/human_g1k_v38.fasta --input ../MAPPING/SAMPLE.bam --dont-use-soft-clipped-bases true --output SAMPLE.mutect.variant
'''

Answers

  • bhanuGandhambhanuGandham Cambridge MAMember, Administrator, Broadie, Moderator admin

    Hi @valentinaindio

    What makes you say:

    The total depth without considering the clipped reads should be 27 (14ref and 13 alt)

    Can you please post IGV screenshot of the bamout of the problem region with Show soft-clipped bases turned on.

  • Hi @bhanuGandham
    thanks for your replay. In the following pictures you can find the IGV screenshot with and without the soft clipped bases. As you can see the total coverage after soft-clipping is 27 (14 reference and 13 alternate base). However the Mutect2 count 48 reference and 13 alternate base.

    **
    17 31235687 31235687 C A 17 31235687 . C A . . DP=61;ECNT=2;MBQ=39,39;MFRL=186,187;MMQ=36,33;MPOS=32;POPAF=7.30;TLOD=34.49 GT:AD:AF:DP:F1R2:F2R1:SB 0/1:48,13:0.222:61:14,13:34,0:34,14,0,13
    **

  • bhanuGandhambhanuGandham Cambridge MAMember, Administrator, Broadie, Moderator admin
    edited November 19

    Hi @valentinaindio

    1. The above image is from the bam or bamout?
    2. You mentioned majority of the variants the depth is counted correctly. Can you please post a couple of such records with and without the --dont-use-soft-clipped-bases true option. I am asking for this to see what is different with these other variants where the option works.

    I will then share this info with the developer and figure out why we are seeing this issue.

Sign In or Register to comment.