We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

Make an old version of Picard-tools to run

Hello,

I need to run a tool that my boss want me to run (this one : http://www.appliedbioinformatics.com.au/index.php/SGSGeneLoss if you wan't to see). One of the dependency of the tool is an old version of picard-tools (1,89). Without it, the tool simply won’t run.

My problem is that I cannot manage to make the two required tools (picard-1.89 and sam-1.89) to run. I tried to download them from sourceForge first, and I also tried to compile myself from git, but they just won’t run. I tried different version of java (java 6 from oracle, java 6 from zulu, and java 8) but it changes nothing but the error message.

```

Java 6 (openjdk version "1.6.0-113") from zulu:
/usr/lib/jvm/zulu-6-amd64/jre/bin/java -jar picard-1.89.jar
Exception in thread "main" java.lang.NullPointerException
at sun.launcher.LauncherHelper.getMainClassFromJar(LauncherHelper.java:353)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:402)

java 6 (1.6.0_45) from oracle :
/usr/lib/jvm/oracle-java6-jdk-amd64/bin/java -jar picard-1.89.jar
Failed to load Main-Class manifest attribute from
picard-1.89.jar

java 8 (openjdk version "1.8.0_222")
java -jar picard-1.89.jar
no main manifest atribute in picard-1.89.jar

```

Do you have an idea of were the problem can be from ? I know that it’s an old verision of the tool, but I don’t have the choice. I’m probably doing something wrong somewhere, but I can’t find a solution…

Thanks you in advance,
Regards
Alexandre

Answers

Sign In or Register to comment.