If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

HaplotypeCaller: Record size mismatch! Something went wrong in the merging of alleles


I've trying to use HaplotypeCaller with queue. The qscript is attached. I managed to run it on 2 samples without problem. It also succeed with 44 samples for calling variants on chromosome 1. But when I run the script with 44 samples for the whole exome calling, the following error occurred:

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

org.broadinstitute.sting.utils.exceptions.ReviewedStingException: Record size mismatch! Something went wrong in the merging of alleles.
at org.broadinstitute.sting.gatk.walkers.haplotypecaller.GenotypingEngine.assignGenotypeLikelihoods(
at org.broadinstitute.sting.gatk.traversals.TraverseActiveRegions.processActiveRegion(
at org.broadinstitute.sting.gatk.traversals.TraverseActiveRegions.processActiveRegions(
at org.broadinstitute.sting.gatk.traversals.TraverseActiveRegions.traverse(
at org.broadinstitute.sting.gatk.traversals.TraverseActiveRegions.traverse(
at org.broadinstitute.sting.gatk.executive.LinearMicroScheduler.execute(
at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.execute(
at org.broadinstitute.sting.gatk.CommandLineExecutable.execute(
at org.broadinstitute.sting.commandline.CommandLineProgram.start(
at org.broadinstitute.sting.commandline.CommandLineProgram.start(
at org.broadinstitute.sting.gatk.CommandLineGATK.main(

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 2.4-9-g532efad):
ERROR Please visit the wiki to see if this is a known problem
ERROR If not, please post the error, with stack trace, to the GATK forum
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions
ERROR MESSAGE: Record size mismatch! Something went wrong in the merging of alleles.
ERROR ------------------------------------------------------------------------------------------

The command line I use:

java$TEMP_DIR -Xmx12g -Xms12g -jar Queue-2.4-9/Queue.jar -S HaplotypeCaller.scala -I $BAM_LIST_FILE -R $REF_FILE -sg $SCATTER_NUMBER -jobRunner GridEngine -V_out $OUTPUT_FILE -retry 2 -run

BAM_LIST_FILE contains a list of paths of 44 recalibrated bam files ( not reduced reads bams, I think HaplotypeCaller does support it).

Could anyone tell me if the error is bug or I did anything wrong? Many thanks,


Best Answer


  • byb121byb121 UKMember

    I will update you once I have more findings on this. Thanks.

  • byb121byb121 UKMember
    edited May 2013

    Update: The cause of the problem could not be found, but the lasted version of Queue (2.5.2) has fixed it.

  • CarneiroCarneiro Charlestown, MAMember admin
Sign In or Register to comment.