Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Missing sample_file -sf option in GATK4 SelectVariants

In the port over to gatk SelectVariants the sample name -sn and sample expression -se options made it in, but the sample_file -sf option did not seem to make it. I tried:

gatk SelectVariants \
  -V in.vcf.gz \
  -O out.vcf.gz \
  -RF SampleReadFilter \
  -sample sample_list_file.txt

as a workaround, and it didn't have any errors, but the output file is more than three times the size of the input file, and still shows all the samples.

Answers

  • bhanuGandhambhanuGandham Cambridge MAMember, Administrator, Broadie, Moderator admin

    Hi @rrbutleriii

    I will ask the developers about this. In the mean time you could use the -se option(Regular expression to select multiple samples) to select for samples, so that your work is not interrupted.

    Regards
    Bhanu

Sign In or Register to comment.