We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

Picard tool CleanSam fails when using GCS paths

ruslanafrazerruslanafrazer Member, Broadie

I tried to run CleanSam using both gatk4.0.4.0 and picardcloud.jar, and got the following error in both cases:

Exception in thread "main" htsjdk.samtools.SAMException: Cannot read non-existent file: file:///Users/rfrazer/Projects/moap/testing_staging_area/gs:/5aa919de-0aa0-43ec-9ec3-288481102b6d/tcga/OV/WGA_RepliG/WXS/BI/ILLUMINA/TCGA_MC3.TCGA-04-1335-11A-01W-0489-09.bam
at htsjdk.samtools.util.IOUtil.assertFileIsReadable(IOUtil.java:426)
at htsjdk.samtools.util.IOUtil.assertFileIsReadable(IOUtil.java:413)
at picard.sam.CleanSam.doWork(CleanSam.java:76)
at picard.cmdline.CommandLineProgram.instanceMain(CommandLineProgram.java:282)
at picard.cmdline.PicardCommandLine.instanceMain(PicardCommandLine.java:103)
at picard.cmdline.PicardCommandLine.main(PicardCommandLine.java:113)

The tool tried to look for the provided path in my current directory instead of trying to access GCS.

It was mentioned to me that not all Picard tools work with NIO right now, but all walker tools should. Since this tool is indeed a walker tool, I think this problem is worth looking into.

Also, is it possible to provide me with a list of Picard tools that should be able to work with NIO in GATK4? This will save my team a lot of time.



Issue · Github
by Sheila

Issue Number
Last Updated


Sign In or Register to comment.