If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

funcotator error

zwzhangzwzhang Member, Broadie

Hi, FireCloud team

Sorry for the duplicated question. I just want to update the format.

I ran into a problem recently coming from Funcotator. I initially run Mutect2 coupled with Funcotator on FireCloud, GATK version, but it throw out some error. And I also tried run Funcotator locally and it produces the almost identical error, see below

[June 6, 2018 1:47:32 PM EDT] done. Elapsed time: 12.63 minutes.
java.lang.StringIndexOutOfBoundsException: String index out of range: -61
    at java.lang.String.substring(

I know Funcotator is still in beta version, but want to ask you help me debug this problem and I am also wondering is there any more stable Funcotator.



  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Thank you for updating your format-- It certainly helps to see error messages in code brackets.

    Unfortunately, I'm unable to help you with your error, but I think one of my colleagues @Sheila or @shlee may be able to. I'm moving your question to the GATK forum where they will be able to assist with Funcotator.

  • shleeshlee CambridgeMember, Broadie ✭✭✭✭✭

    Hi @zwzhang,

    The developer says that updating to GATK4.0.5.0 should solve the issue. Also, please be sure to use the latest data sources.

Sign In or Register to comment.