If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Not enough memory for depth of Coverage as single thread

dbeckerdbecker MunichMember ✭✭✭


if I run depthOfCoverage without -nt it crashes somewhere in Chromosome 11 with

ERROR MESSAGE: An error occurred because you did not provide enough memory to run this program. You can use the -Xmx argument (before the -jar argument) to adjust the maximum heap size provided to Java. Note that this is a JVM argument, not a GATK argument.

This can't be the real reason since it only uses around 15% of our 512 Gb.

If I try with -nt 48 it finishes even though it loops over the last interval for about 90 minutes before it really stops. And I can't produce the interval files. So it is not an option for us.

I tried with GATK 3.7 and 3.8 on a local Server. The NextSeq run is composed of 25 panel diagnosics and 3 whole Exome samples.

Is there something we can try or is there information if this happens when using too many samples or to large bam files? Does depthOfCoverage limits itself? Why is there a difference between running with -nt and without?

Thanks in advance,

Best Answer


Sign In or Register to comment.