Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Error message during PhaseByTransition

Hi, I am running PhaseByTransition on a set of 250+ family trios. I am getting this error message:

Sample lgsnd32563jz3 found in data sources but not in pedigree files with STRICT pedigree validation

However, the sample is in the pedigree file. I tried adding the flag recommended in previous forums - --pedigreeValidationType SILENT, but then all the trios were excluded.

Can you advise me on what the problem could be? Here is my command:

java -Xmx8g -jar GenomeAnalysisTK.jar -T PhaseByTransmission -R /Volumes/Thunderbolt/ref_genome/human_g1k_v37.fasta -V /Volumes/Passport2/July2016/merged_vcf/Trios_GATK_all.dbID.db.eff.vcf -ped /Users/Yam/Desktop/Trios.ped -o /Volumes/Passport2/July2016/merged_vcf/Trios_GATK_all.dbID.db.eff_phased.vcf

Best Answer

Answers

  • SheilaSheila Broad InstituteMember, Broadie admin

    @ajc8
    Hi,

    I think you are running the tool on all 250+ trios at once. PhaseByTransmission can only be run on one trio at a time.

    -Sheila

  • ajc8ajc8 Member

    Ok. I pulled out a family trio using vcftools. I'm still getting the same error message with just the family trio. I know for sure that the names in the vcf file match the names in the ped file.

  • SheilaSheila Broad InstituteMember, Broadie admin

    @ajc8
    Hi,

    Just to confirm, you have only one trio in the VCF and one trio in the pedigree? If you have more than one trio in the pedigree, did you code the non-trio members as unrelated?

    Thanks,
    Sheila

  • ajc8ajc8 Member

    hi again,
    I have returned to phasing my trios and I'm still getting the same error message: This is what my ped file looks like:

    IA003 IA003C IA003D IA003M other CRMO

    And the vcf file I have just has the three members of the trio - with identical sample IDs to the ones in the ped file.

    This is the error message I'm getting:

    Sample IA003D found in data sources but not in pedigree files with STRICT pedigree validation

    I appreciate your help on this.

    Thanks,
    Allison

  • ajc8ajc8 Member
Sign In or Register to comment.