Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

ArrayIndexOutOfBoundsException with BaseRecalibrator

VergiliusVergilius ItalyMember

Dear GATK maintainers,

I am using GATK for variant calling and doing IndelRealign and BaseRecalibration before using HaplotypeCaller but getting an error with BaseRecalibrator.

I am using BaseRecalibrator in such a way it is doing it per-chromosome

jre/1.7.0_72/none/bin/java -Xmx4g -jar gatk/3.4.46/jre--1.7.0_72/GenomeAnalysisTK.jar -T BaseRecalibrator -I VN_TRIOS06F_trim_mergepe_align_mrdup_sortidx_realtar_indreal_1.bam -R reference//ucsc.hg19.fa -nct 8 -knownSites db/snp//Mills_and_1000G_gold_standard.indels.hg19.vcf.gz -knownSites db/snp//dbsnp_144_hg19.vcf.gz -cov ReadGroupCovariate -cov QualityScoreCovariate -cov CycleCovariate -cov ContextCovariate -L chrom_reg/chr_1.bed -o VN_TRIOS06F_trim_mergepe_align_mrdup_sortidx_realtar_indreal_baserecal_1.grp

and getting this error:

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

java.lang.ArrayIndexOutOfBoundsException: -30
at org.broadinstitute.gatk.utils.baq.BAQ.calcEpsilon(BAQ.java:185)
at org.broadinstitute.gatk.utils.baq.BAQ.hmm_glocal(BAQ.java:251)
at org.broadinstitute.gatk.utils.baq.BAQ.calcBAQFromHMM(BAQ.java:553)
at org.broadinstitute.gatk.utils.baq.BAQ.calcBAQFromHMM(BAQ.java:610)
at org.broadinstitute.gatk.utils.baq.BAQ.calcBAQFromHMM(BAQ.java:536)
at org.broadinstitute.gatk.utils.baq.BAQ.baqRead(BAQ.java:680)
at org.broadinstitute.gatk.tools.walkers.bqsr.BaseRecalibrator.calculateBAQArray(BaseRecalibrator.java:493)
at org.broadinstitute.gatk.tools.walkers.bqsr.BaseRecalibrator.map(BaseRecalibrator.java:263)
at org.broadinstitute.gatk.tools.walkers.bqsr.BaseRecalibrator.map(BaseRecalibrator.java:136)
at org.broadinstitute.gatk.engine.traversals.TraverseReadsNano$TraverseReadsMap.apply(TraverseReadsNano.java:228)
at org.broadinstitute.gatk.engine.traversals.TraverseReadsNano$TraverseReadsMap.apply(TraverseReadsNano.java:216)
at org.broadinstitute.gatk.utils.nanoScheduler.NanoScheduler$ReadMapReduceJob.run(NanoScheduler.java:471)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 3.4-46-gbc02625):
ERROR
ERROR This might be a bug. Please check the documentation guide to see if this is a known problem.
ERROR If not, please post the error message, with stack trace, to the GATK forum.
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions http://www.broadinstitute.org/gatk
ERROR
ERROR MESSAGE: -30
ERROR ------------------------------------------------------------------------------------------

Can you tell me if there could be something in my input file or is something related with Java or GATK versions?

I tried both with java 1.7 an 1.8, getting the same.

Regards,

Francesco

Answers

  • SheilaSheila Broad InstituteMember, Broadie admin

    @Vergilius
    Hi Francesco,

    I suspect the error is from the use of -nct. Can you try running without -nct 8?
    Also, BaseRecalibrator needs a lot of data to build a proper model. You should really try to run on your entire dataset instead of per-chromosome. Have a look at this thread for more information.

    -Sheila

    P.S. You can check out WDL for ways to speed up your pipeline without using -nt/-nct.

  • VergiliusVergilius ItalyMember

    I am now running it not per-chromosome and I solved.

    Thanks

Sign In or Register to comment.