Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.
We will be out of the office for a Broad Institute event from Dec 10th to Dec 11th 2019. We will be back to monitor the GATK forum on Dec 12th 2019. In the meantime we encourage you to help out other community members with their queries.
Thank you for your patience!

ERROR MESSAGE: com/sun/javadoc/ProgramElementDoc

JinyanJinyan Member
edited January 2013 in Ask the GATK team

Dear expert,

When I run gatk with fellow command,

java -Xmx10g -Xms10g -jar ~/bin/GenomeAnalysisTK-2.3-4-g57ea19f/GenomeAnalysisTK.jar \
-T BaseRecalibrator \
-R Homo_sapiens.GRCh37.63/bak/Homo_sapiens.GRCh37.63.dna.chromosome.fa \
-knownSites ~/bin/GenomeAnalysisTK-2.3-4-g57ea19f/dbsnp_137.hg19.vcf \
-I input_4.bam \
-o mySample_CovarTable_Recal.grp

I got this error:

INFO 22:25:22,825 RMDTrackBuilder - Creating Tribble index in memory for file ~/bin/GenomeAnalysisTK-2.3-4-g57ea19f/dbsnp_137.hg19.vcf

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

java.lang.NoClassDefFoundError: com/sun/javadoc/ProgramElementDoc

ERROR MESSAGE: com/sun/javadoc/ProgramElementDoc
Post edited by Geraldine_VdAuwera on


  • JinyanJinyan Member

    Here the bam file is RNA-seq.

  • pdexheimerpdexheimer Member ✭✭✭✭

    Hmm, this looks like exactly the same error as was reported here: http://gatkforums.broadinstitute.org/discussion/2013/missing-programelementdoc Same version, same error message. Are you by any chance running OpenJDK as well (check the output of "java -version")?

  • rammaramma Member

    I just got this same error with RNA-seq samples using OpenJDK. I am running the RealignerTargetCreator as opposed to the BaseRecalibrator though.

    If I get time I'll test with Sun Java instead. I'm also running GATK on an Ubuntu 12.04 server if that matters.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hey folks, the 'ProgramElementDoc' part of the error seems to be due to a bug in pulling out the exception details. The actual error varies from case to case. We'll fix this in the next release, but in the meantime if you get one of these, please post the entire stack trace so we can help you diagnose the problem.

  • droazendroazen Cambridge, MAMember, Broadie, Dev ✭✭

    This should be fixed in the latest GATK release (2.3-5) -- if those experiencing this problem could try out that version and let us know whether the issue is resolved, it would be helpful.


  • droazendroazen Cambridge, MAMember, Broadie, Dev ✭✭

    I take it back -- after reviewing the 2.3-5 patch, I think the issue is likely not resolved after all. We'll probably push out another patch shortly to fix the "ProgramElementDoc" issue.

  • droazendroazen Cambridge, MAMember, Broadie, Dev ✭✭

    The ProgramElementDoc issue should be fixed in version 2.3-6, which should be released in a few hours.

  • Shrey_SShrey_S Member

    I am facing the same error with the 2.5.2 version:

    INFO 17:14:29,460 ArgumentTypeDescriptor - Dynamically determined type of Sample.GATK.vcf to be VCF
    INFO 17:14:29,493 HelpFormatter - --------------------------------------------------------------------------------
    INFO 17:14:29,493 HelpFormatter - The Genome Analysis Toolkit (GATK) v2.5-2-gf57256b, Compiled 2013/05/01 09:27:02
    INFO 17:14:29,493 HelpFormatter - Copyright (c) 2010 The Broad Institute
    INFO 17:14:29,493 HelpFormatter - For support and documentation go to http://www.broadinstitute.org/gatk
    INFO 17:14:29,497 HelpFormatter - Program Args: -T VariantAnnotator -I Sample.bam -o Sample.GATK.VA.vcf -ls --variant Sample.GATK.vcf -L Sample.GATK.vcf--dbsnp /Drive_D/Databases/dbsnp/hg19_dbsnp137.vcf -R /Drive_D/Databases/genomes/hg19_genome.fa
    INFO 17:14:29,497 HelpFormatter - Date/Time: 2013/06/10 17:14:29
    INFO 17:14:29,497 HelpFormatter - --------------------------------------------------------------------------------
    INFO 17:14:29,497 HelpFormatter - --------------------------------------------------------------------------------
    INFO 17:14:29,509 ArgumentTypeDescriptor - Dynamically determined type of /Drive_D/SotwareVerTesting/Sample.GATK.vcf to be VCF
    INFO 17:14:29,518 ArgumentTypeDescriptor - Dynamically determined type of /Drive_D/Databases/dbsnp/hg19_dbsnp137.vcf to be VCF
    INFO 17:14:29,574 GenomeAnalysisEngine - Strictness is SILENT
    INFO 17:14:29,804 GenomeAnalysisEngine - Downsampling Settings: Method: BY_SAMPLE, Target Coverage: 1000
    INFO 17:14:29,811 SAMDataSource$SAMReaders - Initializing SAMRecords in serial
    INFO 17:14:29,835 SAMDataSource$SAMReaders - Done initializing BAM readers: total time 0.02
    INFO 17:14:29,859 RMDTrackBuilder - Loading Tribble index from disk for file /Drive_D/SotwareVerTesting/Sample.GATK.vcf
    INFO 17:14:29,909 RMDTrackBuilder - Loading Tribble index from disk for file /Drive_D/Databases/dbsnp/hg19_dbsnp137.vcf
    INFO 17:14:30,133 IntervalUtils - Processing 36 bp from intervals
    INFO 17:14:30,198 GenomeAnalysisEngine - Creating shard strategy for 1 BAM files
    INFO 17:14:30,241 GenomeAnalysisEngine - Done creating shard strategy
    INFO 17:14:30,241 ProgressMeter - Location processed.sites runtime per.1M.sites completed total.runtime remaining

    ERROR ------------------------------------------------------------------------------------------
    ERROR stack trace

    java.lang.NoClassDefFoundError: com/sun/javadoc/ProgramElementDoc
    at org.broadinstitute.sting.gatk.walkers.annotator.VariantAnnotator.initialize(VariantAnnotator.java:194)
    at org.broadinstitute.sting.gatk.executive.LinearMicroScheduler.execute(LinearMicroScheduler.java:84)
    at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.execute(GenomeAnalysisEngine.java:286)
    at org.broadinstitute.sting.gatk.CommandLineExecutable.execute(CommandLineExecutable.java:113)
    at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:245)
    at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:152)
    at org.broadinstitute.sting.gatk.CommandLineGATK.main(CommandLineGATK.java:91)
    Caused by: java.lang.ClassNotFoundException: com.sun.javadoc.ProgramElementDoc
    at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    ... 7 more

    ERROR ------------------------------------------------------------------------------------------
    ERROR A GATK RUNTIME ERROR has occurred (version 2.5-2-gf57256b):
    ERROR Please check the documentation guide to see if this is a known problem
    ERROR If not, please post the error, with stack trace, to the GATK forum
    ERROR Visit our website and forum for extensive documentation and answers to
    ERROR commonly asked questions http://www.broadinstitute.org/gatk
    ERROR MESSAGE: com/sun/javadoc/ProgramElementDoc
    ERROR ------------------------------------------------------------------------------------------
  • droazendroazen Cambridge, MAMember, Broadie, Dev ✭✭

    I can confirm that this is a regression in GATK 2.5-2. I'll file a bug report, and we should have this fixed in time for the 2.6 release (or an upcoming nightly build, if you don't want to wait that long).

  • Shrey_SShrey_S Member

    Alright droazen...Thanks :)

Sign In or Register to comment.