Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.
We will be out of the office for a Broad Institute event from Dec 10th to Dec 11th 2019. We will be back to monitor the GATK forum on Dec 12th 2019. In the meantime we encourage you to help out other community members with their queries.
Thank you for your patience!

IndelRealigner and --downsample_to_coverage / -dcov

mikepmikep Albany, NYMember

I ran the IndelRealigner tool with this option: --downsample_to_coverage 100000. i see this output line, which leads me to believe the downsample option was recognized:
INFO 09:42:26,159 GenomeAnalysisEngine - Downsampling Settings: Method: BY_SAMPLE, Target Coverage: 100000

yet, i also see multiple lines like this in the output:
INFO 09:43:59,101 IndelRealigner - Not attempting realignment in interval gi|224589819:117115017-117313719:44370-44521 because there are too many reads.

i thought the downsampling would alleviate excluding regions where too many reads are present? i do believe the regions are being excluded because the IndelRealigner tool completes quickly, as compare to runs i've made when i've set the max to align to 100000.

to be explicit, i want all regions included in processing, and i'm willing to down sample to make this happen.

thanks for the help.

Best Answers


  • SheilaSheila Broad InstituteMember, Broadie admin


    I wonder if the interval it skipped has more than 100,000 reads. Instead of trying to set the downsampling threshold, can you try setting -maxInMemory to a really high number? Also, please do set -maxRead to a really high number as well.


  • mikepmikep Albany, NYMember

    thanks for you prompt response.

    The regions likely do have more than 100,000 reads - or close to it. i've checked some of the regions w/ depth of coverage tool and see that coverage is in this neighborhood.

    i have already experimented with the -maxRead, setting its value to 100000. those runs ran (obviously, much slower), but i still had some regions excluded because the number of reads exceed 100000. my thought is that 100000 reads is enough and i'd like to simply downsample to that value and include all regions, rather than keep increasing -maxRead until no regions are kick out.

    so... still... any idea why specifying -dcov 100000 doesn't appear to downsample? or, how can i get Indelrealigner to down sample.


  • mikepmikep Albany, NYMember

    ok, thanks. that makes sense.

    it seems that i could use -dcov and -maxReads together? am i correct in thinking that if i increase the -maxReads allowed to IndelRealigner, i won't have to lower the -dcov target as much?

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Yes, that should work.

Sign In or Register to comment.