We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

Pooled DNA sequencing- variant calling using HaplotypeCaller

sudarshansudarshan Princeton UniversityMember

I am trying to perform variant calling using HaplotypeCaller for Drosophila melanogaster pooled sequencing data. I have 50 pools in total and each pool consists of DNA from 60 individuals, sequenced at an average coverage of 40-50X. So my ploidy per pool in is 120. I have previously performed mapping using BWA, filtered out low quality reads, removed duplicates and performed indel realignment. I have split the BAM files and headers by chromosome (to reduce the file size and perform variant calling only on the main chromosomes).

I am giving the program 14-20days to run, 128gb memory and heap size (-Xmx) of 32g.  I have reduced the maxAltalles to 3 and 2. Besides reducing the maxAltalleles and changing ploidy to 120, everything else is set to default. I have tried variant calling directly and jointly on all relevant files. I have also tried the -ERC GVCF mode for single files. But I cannot get the program to finish running i.e. I do not get any explicit errors but after ~12-24 hrs the progress gets stuck at one region for the remainder of time and I get the out of time limit/ resource error, for example,

INFO 21:05:08,999 ProgressMeter - 4:335975 0.0 11.4 h 15250.3 w 24.9% 45.9 h 34.5 h (Day 1)
INFO 11:00:05,736 ProgressMeter - 4:335975 0.0 14.1 d 15250.3 w 24.9% 8.1 w 6.1 w (Day 14)

I am using GATK version 3.4-46. This pattern holds for all of the chromosomes, HC modes and different file sizes (ranging from ~35MB to over 1GB). I have used Samtools mpileup to do the same and am able to get a vcf output jointly for many files in ~2-3 days.

Please let me know if there is a problem that I am unable to see.

Issue · Github
by Sheila

Issue Number
Last Updated
Closed By


Sign In or Register to comment.