Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Empty VCF file after runnin gHaplotypeCaller

m.brozynskam.brozynska AustraliaMember

Hi GATK team,

I'm running HaplotypeCaller using the following command:

-T HaplotypeCaller -R all.chrs.fasta -I filename.bam -o filename.vcf -stand_emit_conf 10 -stand_call_conf 20 -nct 8 -rf BadCigar

on PacBio reads aligned to a reference genome using BWA.

I don't know why I'm getting an empty VCF file. Please find attached the log file. I see that ~50% of the reads are filtered out but the second half should produce some variants, shouldn't it? Is it a coverage issue now?

Appreciate a lot you help and thanks in advance for any piece of advice!

Tagged:

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Perhaps. It could be that all the variant calls are very low confidence and are filtered out by the confidence thresholds. Try lowering the confidence thresholds, or calling with -ERC GVCF to output a gVCF output.

  • m.brozynskam.brozynska AustraliaMember

    I followed your advice and first called -ERC GVCF as output. I got a huge output file but there was no variants! So second I lowered the confidence thresholds until I got to
    -stand_emit_conf 1 -stand_call_conf 1 -mbq 1 -mmq 1
    which I guess is the min... and I got no variants! The reads that got filtered put dropped to only ~5%.
    I tried playing with other parameters as well but with no luck. I still think it's a read depth issue...
    If you have any idea what could be my next step I'll appreciate a lot!

  • tommycarstensentommycarstensen United KingdomMember ✭✭✭

    @m.brozynska What happens if you run without -rf BadCigar? Why are you running with -rf BadCigar?

    This is suspicious:

    INFO  11:25:32,438 MicroScheduler -   -> 49556 reads (0.37% of total) failing BadCigarFilter 
    INFO  11:25:32,439 MicroScheduler -   -> 7077364 reads (52.42% of total) failing HCMappingQualityFilter 
    

    Did you align to all.chrs.fasta using bwa?

    Very odd. Sorry I'm not of more help.

Sign In or Register to comment.