Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Ca I make use of Beagle to identify the shared haplotype among a pair of brothers who are haploid

Hi, I am trying to identify the shared region of genome among several pair of brothers in ant who are haploid. I have run the GATK variant discovery pipeline and currently I have VCF file which have only the Homozygous snps as expected. Now can anyone help me to know whether I can make use of beagle to get the shared/common haplotype information from the pair of brothers.also correct me if I am doing something wrong as I new to this field.

PS as of the VCF is unphased.

Tagged:

Best Answers

Answers

  • kshitij_tandonkshitij_tandon TaipeiMember

    @tommycarstensen thanks for the information .. do you know any such tool that can do this for me

  • SheilaSheila Broad InstituteMember, Broadie admin

    @kshitij_tandon
    Hi,

    I suspect you are not using the latest version of GATK like I told you to!
    You should really upgrade and follow the GVCF workflow for the best results. http://gatkforums.broadinstitute.org/discussion/3893/calling-variants-on-cohorts-of-samples-using-the-haplotypecaller-in-gvcf-mode
    The final VCF you get will have phasing information.

    -Sheila

  • kshitij_tandonkshitij_tandon TaipeiMember

    @Sheila I tried running the latest version with the following command line but it all goes in vain as it encounters the RUN TIME ERROR every time.. after going through few discussion on GATK i found that there is a bug with -nct option so i removed that from the command line. However, still it encounters errors .. I am on a very tight schedule to finish this work so if i run with the old GTAK version .. can there be any option to get the things i want.

    Thanks in advance for all the help

  • kshitij_tandonkshitij_tandon TaipeiMember

    java -Xmx2g -jar /location for GATK.jar -T HaplotypeCaller -R /location/reference -I /location to .bam --emitRefConfidence GVCF --variant_index_type LINEAR --variant_index_parameter 128000 -ploidy 1 -o /location to outputwith .g.vcf

    It runs for approx 10 % and then breaks of with the following error

    INFO 13:43:08,309 GATKRunReport - Uploaded run statistics report to AWS S3

    ERROR ------------------------------------------------------------------------------------------
    ERROR stack trace

    java.lang.IllegalArgumentException
    at java.nio.ByteBuffer.allocate(ByteBuffer.java:330)
    at htsjdk.samtools.reference.IndexedFastaSequenceFile.getSubsequenceAt(IndexedFastaSequenceFile.java:195)
    at org.broadinstitute.gatk.utils.fasta.CachingIndexedFastaSequenceFile.getSubsequenceAt(CachingIndexedFastaSequenceFile.java:329)
    at org.broadinstitute.gatk.utils.activeregion.ActiveRegion.getReference(ActiveRegion.java:220)
    at org.broadinstitute.gatk.utils.activeregion.ActiveRegion.getActiveRegionReference(ActiveRegion.java:186)
    at org.broadinstitute.gatk.utils.activeregion.ActiveRegion.getActiveRegionReference(ActiveRegion.java:172)
    at org.broadinstitute.gatk.tools.walkers.haplotypecaller.HaplotypeCaller.createReferenceHaplotype(HaplotypeCaller.java:1013)
    at org.broadinstitute.gatk.tools.walkers.haplotypecaller.HaplotypeCaller.referenceModelForNoVariation(HaplotypeCaller.java:1033)
    at org.broadinstitute.gatk.tools.walkers.haplotypecaller.HaplotypeCaller.map(HaplotypeCaller.java:807)
    at org.broadinstitute.gatk.tools.walkers.haplotypecaller.HaplotypeCaller.map(HaplotypeCaller.java:226)
    at org.broadinstitute.gatk.engine.traversals.TraverseActiveRegions$TraverseActiveRegionMap.apply(TraverseActiveRegions.java:709)
    at org.broadinstitute.gatk.engine.traversals.TraverseActiveRegions$TraverseActiveRegionMap.apply(TraverseActiveRegions.java:705)
    at org.broadinstitute.gatk.utils.nanoScheduler.NanoScheduler$ReadMapReduceJob.run(NanoScheduler.java:471)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
    at java.util.concurrent.FutureTask.run(FutureTask.java:262)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)

    ERROR ------------------------------------------------------------------------------------------
    ERROR A GATK RUNTIME ERROR has occurred (version 3.4-46-gbc02625):
    ERROR
    ERROR This might be a bug. Please check the documentation guide to see if this is a known problem.
    ERROR If not, please post the error message, with stack trace, to the GATK forum.
    ERROR Visit our website and forum for extensive documentation and answers to
    ERROR commonly asked questions http://www.broadinstitute.org/gatk
    ERROR
    ERROR MESSAGE: Code exception (see stack trace for error itself)
    ERROR ------------------------------------------------------------------------------------------
Sign In or Register to comment.