We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

Argument with name '--referenceFile' (-R) is missing.

jfarrelljfarrell Member ✭✭

When running the latest version of GenomeSTRiP (Genome STRiP 2.00.1572), the following error occurs even thought the reference was specified.

INFO 08:31:34,818 QGraph - 0 Pend, 1 Run, 0 Fail, 145 Done
ERROR 08:34:04,683 FunctionEdge - Error: 'java' '-Xmx2048m' '-XX:+UseParallelOldGC' '-XX:ParallelGCThreads=4' '-XX:GCTimeLimit=50' '-XX:GC HeapFreeLimit=10' '-Djava.io.tmpdir=/restricted/projectnb/casa/sv/gs/tmpdir.bcm' '-cp' '/restricted/projectnb/casa/sv/gs/svtoolkit/lib/SVToolk it.jar:/restricted/projectnb/casa/sv/gs/svtoolkit/lib/gatk/GenomeAnalysisTK.jar:/restricted/projectnb/casa/sv/gs/svtoolkit/lib/gatk/Queue.jar' '-cp' '/restricted/projectnb/casa/sv/gs/svtoolkit/lib/SVToolkit.jar:/restricted/projectnb/casa/sv/gs/svtoolkit/lib/gatk/GenomeAnalysisTK.jar:/re stricted/projectnb/casa/sv/gs/svtoolkit/lib/gatk/Queue.jar' 'org.broadinstitute.sv.apps.MergeGenotyperOutput' '-O' '/restricted/projectnb/casa /sv/gs/adsp.wgs.bcm.genome_strip.del.1kg.genotypes.vcf' '-runDirectory' 'run.bcm'
ERROR 08:34:04,728 FunctionEdge - Contents of /restricted/projectnb/casa/sv/gs/run.bcm/logs/SVGenotyper-146.out:
Exception in thread "main" org.broadinstitute.gatk.utils.commandline.MissingArgumentException:
Argument with name '--referenceFile' (-R) is missing.
at org.broadinstitute.gatk.utils.commandline.ParsingEngine.validate(ParsingEngine.java:299)
at org.broadinstitute.gatk.utils.commandline.ParsingEngine.validate(ParsingEngine.java:279)
at org.broadinstitute.gatk.utils.commandline.CommandLineProgram.start(CommandLineProgram.java:224)
at org.broadinstitute.gatk.utils.commandline.CommandLineProgram.start(CommandLineProgram.java:155)
at org.broadinstitute.sv.commandline.CommandLineProgram.runAndReturnResult(CommandLineProgram.java:29)
at org.broadinstitute.sv.commandline.CommandLineProgram.run(CommandLineProgram.java:25)
at org.broadinstitute.sv.apps.MergeGenotyperOutput.main(MergeGenotyperOutput.java:43)
INFO 08:34:04,729 QGraph - Writing incremental jobs reports...
INFO 08:34:04,732 QGraph - 0 Pend, 0 Run, 1 Fail, 145 Done
INFO 08:34:04,735 QCommandLine - Writing final jobs report...
INFO 08:34:04,736 QCommandLine - Done with errors


  • skashinskashin Member ✭✭


    I tried to reproduce your problem, but genotyping in my deployment of 2.00.1572 seems to work fine.
    Can you post the script you invoke, so I know exactly what parameters you are passing?


  • jfarrelljfarrell Member ✭✭

    When I updated to the new version, I just updated the jar file (did not update the qscripts for example). Could that have caused the error?

    java -cp ${classpath} ${mx} -Djava.io.tmpdir=$SV_TMPDIR\
            org.broadinstitute.gatk.queue.QCommandLine \
            -S ${SV_DIR}/qscript/SVGenotyper.q \
            -S ${SV_DIR}/qscript/SVQScript.q \
            --disableJobReport \
            -gatk ${SV_DIR}/lib/gatk/GenomeAnalysisTK.jar \
            -cp ${classpath} \
             -configFile ${SV_DIR}/conf/genstrip_parameters.txt \
            -tempDir ${SV_TMPDIR} \
            -R $REF \
            -genderMapFile adsp_gender.map \
            -runDirectory ${runDir} \
            -md ${runDir}/metadata \
            -disableGATKTraversal \
            -jobLogDir ${runDir}/logs \
            -I ${bam} \
            -vcf ${sites} \
            -O ${genotypes} \
            -jobRunner GridEngine\
            -parallelRecords 100\
            -run \
            || exit 1
  • skashinskashin Member ✭✭

    Yes, absolutely, it's almost guaranteed to cause a problem as our Java code assumes it is called with the right arguments by Queue scripts.
    I would definitely try a clean deployment of r1572

  • jfarrelljfarrell Member ✭✭

    Thanks! The clean deployment worked. That will be the first and last time I will try just updating the jar.

  • bhandsakerbhandsaker Member, Broadie ✭✭✭✭
    edited May 2015

    Yes, in r1565 we added code to automatically bgzip the intermediate files to save space and this necessitated passing the reference sequence to some steps that didn't require it previously.

    Post edited by bhandsaker on
Sign In or Register to comment.