Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.
Attention:
We will be out of the office for a Broad Institute event from Dec 10th to Dec 11th 2019. We will be back to monitor the GATK forum on Dec 12th 2019. In the meantime we encourage you to help out other community members with their queries.
Thank you for your patience!

Haplotype caller 3.2 versions not calling a true variant

KTombergKTomberg University of MichiganMember

Hi! I have just run the 3.2.2 and 3.2.0 versions on the same bam file and I noticed that it is not calling a true variant, while the earlier version 3.1.1 calls it. Everything in the command is identical aside from GATK haplotype caller version. Any ideas why this variant is not called and how to address that? (it's the middle variant chr10:43022236)
Thanks for all the ideas!

GATKCommandLine=<ID=HaplotypeCaller,Version=3.1-1-g07a4bf8,Date="Mon Aug 25 15:45:14 EDT

10 42823862 . C T 125.77 . AC=1;AF=0.500;AN=2;BaseQRankSum=-1.568;ClippingRankSum=-0.633;DP=11;FS=8.751;MLEAC=1;MLEAF=0.500;MQ=57.87;MQ0=0;MQRankSum=-1.036;QD=11.43;ReadPosRankSum=0.000 GT:ADP:GQ:PL 0/1:4,6:10:99:154,0,121
10 43022236 . A C 119.77 . AC=1;AF=0.500;AN=2;BaseQRankSum=1.368;ClippingRankSum=0.421;DP=8;FS=0.000;MLEAC=1;MLEAF=0.500;MQ=60.00;MQ0=0;MQRankSum=0.421;QD=14.97;ReadPosRankSum=-0.421 GT:ADP:GQ:PL 0/1:4,4:8:99:148,0,129
10 43159396 . G A 21.77 LowQual AC=2;AF=1.00;AN=2;DP=2;FS=0.000;MLEAC=2;MLEAF=1.00;MQ=60.00;MQ0=0;QD=10.88 GT:ADP:GQ:PL 1/1:0,2:2:6:49,6,0

GATKCommandLine=<ID=HaplotypeCaller,Version=3.2-0-g289df4b,Date="Mon Aug 25 15:46:43 EDT

10 42823862 . C T 118.77 . AC=1;AF=0.500;AN=2;BaseQRankSum=-1.568;ClippingRankSum=-1.036;DP=11;FS=8.751;MLEAC=1;MLEAF=0.500;MQ=57.87;MQ0=0;MQRankSum=0.000;QD=10.80;ReadPosRankSum=0.365 GT:ADP:GQ:PL 0/1:4,6:10:99:147,0,124
10 43159396 . G A 21.77 LowQual AC=2;AF=1.00;AN=2;DP=2;FS=0.000;MLEAC=2;MLEAF=1.00;MQ=60.00;MQ0=0;QD=10.88 GT:ADP:GQ:PL 1/1:0,2:2:6:49,6,0

GATKCommandLine=<ID=HaplotypeCaller,Version=3.2-2-gec30cee,Date="Mon Aug 25 13:43:53 EDT

10 42823862 . C T 118.77 . AC=1;AF=0.500;AN=2;BaseQRankSum=-1.568;ClippingRankSum=-0.365;DP=11;FS=8.751;MLEAC=1;MLEAF=0.500;MQ=57.87;MQ0=0;MQRankSum=-0.741;QD=10.80;ReadPosRankSum=0.365 GT:ADP:GQ:PL 0/1:4,6:10:99:147,0,124
10 43159396 . G A 21.77 LowQual AC=2;AF=1.00;AN=2;DP=2;FS=0.000;MLEAC=2;MLEAF=1.00;MQ=60.00;MQ0=0;QD=10.88 GT:ADP:GQ:PL 1/1:0,2:2:6:49,6,0

Answers

  • aeonsimaeonsim Member ✭✭✭

    It may be a case similar to this, run GATK HC with the bamout option for the region and see what it's doing.
    http://gatkforums.broadinstitute.org/discussion/4482/gatk-3-2-2-n-1-haplotypecaller-missing-alt-alleles#latest

  • SheilaSheila Broad InstituteMember, Broadie admin

    @KTomberg‌

    Hi,

    Can you tell me your exact command line?

    We may need a snippet of the region that is causing the error to debug it locally. This may very well be related to aeonsim's bug.

    Thanks,
    Sheila

  • KTombergKTomberg University of MichiganMember

    here is the command, the only thing I changed is the version of GATK

    /home/ginsburg_lab/club_house/software/GenomeAnalysisTK-3.1-1/GenomeAnalysisTK.jar
    /home/ginsburg_lab/club_house/software/GenomeAnalysisTK-3.2-0/GenomeAnalysisTK.jar
    /home/ginsburg_lab/club_house/software/GenomeAnalysisTK-3.2-2/GenomeAnalysisTK.jar

    /home/ginsburg_lab/club_house/etc/garage/jdk1.7.0_07/bin/java -Xmx15g -jar /home/ginsburg_lab/club_house/software/GenomeAnalysisTK-3.2-0/GenomeAnalysisTK.jar -R /home/ginsburg_lab/club_house/database/mouse_ref/BWA_index_ensembl_GCGm38.73/Mus_musculus.GRCm38.73.dna.toplevel.fa -T HaplotypeCaller -I 82305_sampe_sort_nodup_realigner_fixmate.bam -o 82305_sampe_sort_nodup_realigner_fixmate_haplocaller_v3.2-0.vcf -stand_call_conf 50.0 -stand_emit_conf 10.0 -nct 8

  • SheilaSheila Broad InstituteMember, Broadie admin

    @KTomberg‌

    Hi,

    We will need a snippet of the data that is causing the error. This does seem similar to aeonsim's issue.

    Instructions for how to upload necessary files are here: http://gatkforums.broadinstitute.org/discussion/1894/how-do-i-submit-a-detailed-bug-report

    Thanks!

    -Sheila

  • wchenwchen Member
    edited January 2015

    We have a variant of >30% frequency according to recalibrated BAM in GATK, but failed to get called by GATK3.3 HaplotypeCaller too. It was correctly called if marking and removing duplication was used (it's amplicon-based data with overlapping). But BAM file from -bamout during HaplotypeCaller also showed there was 11% alt allele. Why the mutation was not called?

    Another case in IGV showed that the varfreq was 2% instead of 13% in Miseq Reporter because the primer sequences were not soft-clipped in fastq files, and somehow diluted the mutation allele in this case. Was trying to soft-clip the primer sequence (22-32 nt long) before variant calling, got this error:
    -T ClipReads -R ucsc.hg19.fasta -I recal3.3.bam -o recal_3.3_clipped.bam -CT 1-22 -CR SOFTCLIP_BASES -os clip.stat --validation_strictness LENIENT
    Read Clipper cannot soft clip unmapped reads
    Why? These should be all mapped reads.

    Thanks!

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    @wchen I'm sorry but I'm having a really hard time understanding what you are asking. Can you please post this as a new question (not as a comment) and describe in more detail what steps you have performed, what were the results, and what you think is problematic?

  • wchenwchen Member

    I'm sorry but I'm having a really hard time understanding what you are asking. Can you please post this as a new question (not as a comment) and describe in more detail what steps you have performed, what were the results, and what you think is problematic?

    Sorry please ignore the first part. Just this:
    I was trying to soft-clip the first 32 bp before variant calling:
    -T ClipReads -R ucsc.hg19.fasta -I recal3.3.bam -o recal_3.3_clipped.bam -CT 1-22 -CR SOFTCLIP_BASES -os clip.stat --validation_strictness LENIENT
    but got this error:
    'Read Clipper cannot soft clip unmapped reads'

    Why? The input BAM is aligned reads already. Thanks!

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    I answered in your new question thread.

Sign In or Register to comment.