We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

Somehow the requested coordinate is not covered by the read?

tommycarstensentommycarstensen United KingdomMember ✭✭✭

I was running some samtools calls through UG with genotyping_mode GENOTYPE_GIVEN_ALLELES after reading this thread:


I got this error message:

##### ERROR MESSAGE: Somehow the requested coordinate is not covered by the read. Alignment 440969 | 36S26M1D6M1I2M1D1M3D27M1S

What did I do wrong? It works for most other fragments (chrom20:pos1-pos2). Is it possible to avoid this error message and just do ./. calls at coordinates not covered by reads? I'm not sure, why samtools called at a coordinate not covered by a read. I don't know at which coordinate this happened. I was at this coordinate, when the error happened:

INFO  10:21:06,036 ProgressMeter -       20:479014   2329564.0    55.0 m      23.6 m        0.6%     6.7 d       6.7 d 

I was using this command:

$java -Djava.io.tmpdir=tmp -Xmx63900m \
 -jar $jar \
 --analysis_type UnifiedGenotyper \
 --reference_sequence $ref \
 --input_file bam.list \
 --dbsnp $dbsnp138 \
 --num_cpu_threads_per_data_thread 3 \
 --num_threads 4 \
 --out $out \
 --intervals $vcf \
 -stand_call_conf 10 \
 -stand_emit_conf 10 \
 --genotype_likelihoods_model BOTH \
 --output_mode EMIT_ALL_SITES \
 --annotation Coverage -A FisherStrand -A HaplotypeScore -A MappingQualityRankSumTest -A QualByDepth -A RMSMappingQuality -A ReadPosRankSumTest \
 --alleles $vcf \
 --genotyping_mode GENOTYPE_GIVEN_ALLELES \
 -L 20:$pos1-$pos2 \

Best Answers


  • tommycarstensentommycarstensen United KingdomMember ✭✭✭

    @Geraldine_VdAuwera‌ I'm terribly sorry about having set free an avalanche of bugs. I hope you manage to kill them all. I have to admit, that I'm using version 3.2. I was in the middle of an analysis and it was not an option to switch to 3.3. I am happy to try and reproduce the error message with 3.3 at the end of this week or the beginning of next week. Actually, I just started that job. I'm assuming multithreading is safe to use. I'm travelling tomorrow, but will try to report back on the 3.3 outcome.

  • tommycarstensentommycarstensen United KingdomMember ✭✭✭

    @Geraldine_VdAuwera‌ here a delayed and poor response. I can't replicate this bug.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    I love it when a bug goes away by itself.

  • tommycarstensentommycarstensen United KingdomMember ✭✭✭

    Unfortunately I was able to replicate this with versions 3.2 and 3.3. I posted about this elsewhere, so I will "close" this thread.

  • Hi Geraldine,

    It is my turn to have to deal with this error message:

    MESSAGE: Somehow the requested coordinate is not covered by the read. Alignment 56487654 | 66S19M6D16M

    As previous users found out, the message appears to be random, as I have been able to run files successfully through when I had previously gotten that error. However, some files I have not yet gotten too work at all.
    My command is:
    java -Xmx4g -jar /usr/product/bioinfo/GATK/3.1.1/GenomeAnalysisTK.jar -T UnifiedGenotyper -nct 6 -I 14.recal.bam -I 15B.recal.bam -I 16B.recal.bam -I 18B.recal.bam -I AH15.recal.bam -I AH23.recal.bam -I B2C.recal.bam -I C1.recal.bam -I E1.recal.bam -I F1B.recal.bam -I JR11.recal.bam -I JR15.recal.bam -I JR2-F1C.recal.bam -I JR5-F1C.recal.bam -I JR7-F1C.recal.bam -I JR8-F1A.recal.bam -I TP121B.recal.bam -I TP17-2.recal.bam -I TP1.recal.bam -I TP3-92.recal.bam -I TP4a.recal.bam -I TP51D.recal.bam -I TP7-10F1A2.recal.bam -I TP81B.recal.bam -R /usr/users/bharr/ILLUMINA/Mus_musculus.GRCm38.74.dna.chromosome.fa -L 15 --dbsnp mgp.v3.snps.rsIDdbSNPv137.vcf -o 15_INDEL.vcf -U ALLOW_UNSET_BAM_SORT_ORDER -gt_mode DISCOVERY -glm INDEL -mbq 20 -stand_emit_conf 10 -dcov 300 -G Standard -A AlleleBalance -rf DuplicateRead -rf FailsVendorQualityCheck -rf NotPrimaryAlignment -rf BadMate -rf MappingQualityUnavailable -rf UnmappedRead -rf BadCigar --filter_mismatching_base_and_quals

    Thank you very much!

  • tommycarstensentommycarstensen United KingdomMember ✭✭✭

    @Bettina_Harr I was able to run my jobs. I just kept trying, when they failed. See the other thread. Perhaps also try changing -nct 6 to -nct 2 -nt 4. If your data is not high coverage, then you should be using HaplotypeCaller instead. Good luck!

  • Thank you tommycarstensen. I'll try that change.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Good luck! Unfortunately we can't address this easily because it occurs so randomly, and it's low priority because it can be overcome by repeating jobs.

    As an aside, I would recommend avoiding using any -U arguments ever; if you find you need one, there's usually a problem that you would be better off fixing up front. (Except the -U to allow N cigars in RNAseq -- that's our fault).

  • brilliant, -nct 2 -nt 4 worked!

  • Thank you Geraldine. I removed the -U option.

  • DavidNixDavidNix Member

    Not sure if this thread is alive? I see the same error when running MuTect2. The work around is to not use the -nct option.

    Failing run:
    INFO 14:01:54,853 HelpFormatter - ----------------------------------------------------------------------------------
    INFO 14:01:54,856 HelpFormatter - The Genome Analysis Toolkit (GATK) v3.6-0-g89b7209, Compiled 2016/06/01 22:27:29
    INFO 14:01:54,856 HelpFormatter - Copyright (c) 2010-2016 The Broad Institute
    INFO 14:01:54,856 HelpFormatter - For support and documentation go to https://www.broadinstitute.org/gatk
    INFO 14:01:54,856 HelpFormatter - [Mon Aug 22 14:01:54 MDT 2016] Executing on Linux 2.6.32-573.18.1.el6.x86_64 amd64
    INFO 14:01:54,856 HelpFormatter - Java HotSpot(TM) 64-Bit Server VM 1.8.0_65-b17 JdkDeflater
    INFO 14:01:54,859 HelpFormatter - Program Args: -T MuTect2 -o 1vs3Con.vcf -I:tumor 13611X1_160810_D00550_0369_BC9JH4ANXX_filtered.bam -I:normal 13611X3_160810_D00550_0369_BC9JH4ANXX_filtered.bam -nct 48 -R /uufs/chpc.utah.edu/common/home/u0028003/HCIAtlatl/data/Human/B37/human_g1k_v37_decoy_phiXAdaptr.fasta --dbsnp /uufs/chpc.utah.edu/common/home/u0028003/HCIAtlatl/data/Human/B37/MuTect/dbsnp_132_b37.leftAligned.vcf --cosmic /uufs/chpc.utah.edu/common/home/u0028003/HCIAtlatl/data/Human/B37/MuTect/b37_cosmic_v54_120711.vcf
    INFO 14:01:54,868 HelpFormatter - Executing as [email protected] on Linux 2.6.32-573.18.1.el6.x86_64 amd64; Java HotSpot(TM) 64-Bit Server VM 1.8.0_65-b17.
    INFO 14:01:54,868 HelpFormatter - Date/Time: 2016/08/22 14:01:54
    INFO 14:01:54,868 HelpFormatter - ----------------------------------------------------------------------------------
    INFO 14:01:54,868 HelpFormatter - ----------------------------------------------------------------------------------
    INFO 14:01:54,955 GenomeAnalysisEngine - Strictness is SILENT
    INFO 14:01:55,083 GenomeAnalysisEngine - Downsampling Settings: Method: BY_SAMPLE, Target Coverage: 1000
    INFO 14:01:55,088 SAMDataSource$SAMReaders - Initializing SAMRecords in serial
    INFO 14:01:55,157 SAMDataSource$SAMReaders - Done initializing BAM readers: total time 0.07
    INFO 14:01:55,533 MicroScheduler - Running the GATK in parallel mode with 48 total threads, 48 CPU thread(s) for each of 1 data thread(s), of 48 processors available on this machine
    INFO 14:01:55,616 GenomeAnalysisEngine - Preparing for traversal over 2 BAM files
    INFO 14:01:55,757 GenomeAnalysisEngine - Done preparing for traversal
    INFO 14:01:55,757 ProgressMeter - | processed | time | per 1M | | total | remaining
    INFO 14:01:55,757 ProgressMeter - Location | active regions | elapsed | active regions | completed | runtime | runtime
    INFO 14:01:55,810 MuTect2 - Using global mismapping rate of 45 => -4.5 in log10 likelihood units
    INFO 14:01:55,811 PairHMM - Performance profiling for PairHMM is disabled because the program is being run with multiple threads (-nct>1) option
    Profiling is enabled only when running in single thread mode

    Using AVX accelerated implementation of PairHMM
    INFO 14:01:57,222 VectorLoglessPairHMM - libVectorLoglessPairHMM unpacked successfully from GATK jar file
    INFO 14:01:57,223 VectorLoglessPairHMM - Using vectorized implementation of PairHMM

    INFO 14:02:25,760 ProgressMeter - 1:1114924 0.0 30.0 s 49.6 w 0.0% 23.5 h 23.4 h

    INFO 15:02:26,211 ProgressMeter - 1:153642979 0.0 60.5 m 6002.7 w 4.9% 20.6 h 19.6 h
    INFO 15:03:26,213 ProgressMeter - 1:154214601 0.0 61.5 m 6101.9 w 4.9% 20.9 h 19.8 h

    ERROR --
    ERROR stack trace

    org.broadinstitute.gatk.utils.exceptions.ReviewedGATKException: Somehow the requested coordinate is not covered by the read. Too many deletions?
    at org.broadinstitute.gatk.utils.sam.ReadUtils.getReadCoordinateForReferenceCoordinate(ReadUtils.java:490)
    at org.broadinstitute.gatk.utils.sam.ReadUtils.getReadCoordinateForReferenceCoordinate(ReadUtils.java:436)
    at org.broadinstitute.gatk.utils.sam.ReadUtils.getReadCoordinateForReferenceCoordinate(ReadUtils.java:427)
    at org.broadinstitute.gatk.utils.clipping.ReadClipper.hardClipByReferenceCoordinates(ReadClipper.java:543)
    at org.broadinstitute.gatk.utils.clipping.ReadClipper.hardClipByReferenceCoordinatesLeftTail(ReadClipper.java:177)
    at org.broadinstitute.gatk.utils.clipping.ReadClipper.hardClipAdaptorSequence(ReadClipper.java:408)
    at org.broadinstitute.gatk.utils.clipping.ReadClipper.hardClipAdaptorSequence(ReadClipper.java:411)
    at org.broadinstitute.gatk.tools.walkers.cancer.m2.MuTect2.finalizeActiveRegion(MuTect2.java:1201)
    at org.broadinstitute.gatk.tools.walkers.cancer.m2.MuTect2.assembleReads(MuTect2.java:1145)
    at org.broadinstitute.gatk.tools.walkers.cancer.m2.MuTect2.map(MuTect2.java:536)
    at org.broadinstitute.gatk.tools.walkers.cancer.m2.MuTect2.map(MuTect2.java:176)
    at org.broadinstitute.gatk.engine.traversals.TraverseActiveRegions$TraverseActiveRegionMap.apply(TraverseActiveRegions.java:709)
    at org.broadinstitute.gatk.engine.traversals.TraverseActiveRegions$TraverseActiveRegionMap.apply(TraverseActiveRegions.java:705)
    at org.broadinstitute.gatk.utils.nanoScheduler.NanoScheduler$ReadMapReduceJob.run(NanoScheduler.java:471)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)

    ERROR ------------------------------------------------------------------------------------------
    ERROR A GATK RUNTIME ERROR has occurred (version 3.6-0-g89b7209):
    ERROR This might be a bug. Please check the documentation guide to see if this is a known problem.
    ERROR If not, please post the error message, with stack trace, to the GATK forum.
    ERROR Visit our website and forum for extensive documentation and answers to
    ERROR commonly asked questions https://www.broadinstitute.org/gatk
    ERROR MESSAGE: Somehow the requested coordinate is not covered by the read. Too many deletions?
    ERROR ------------------------------------------------------------------------------------------
  • SheilaSheila Broad InstituteMember, Broadie ✭✭✭✭✭


    Have a look at this thread.


Sign In or Register to comment.