Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Print Reads --sample_name option doesn't apply to BAM header @RG SM:

tyamaguchityamaguchi CanadaMember

Hi,

I use --sample_name option to restrict output reads for PintReads walker (GATK version - 2.4.9).
This option works well but the output BAM header @RG still contains sample name (SM) that was not included.
Is there a way to apply this --sample_name option to BAM header at the same time?
I could reheader the BAM files using samtools but I'm looking for a better and easier way.

Thank you,

Taka

Best Answer

Answers

Sign In or Register to comment.