Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

I/O error loading or writing tribble index file, ONLY on mounted folders (Ubuntu)

olingercolingerc LuxembourgMember

Hi,
I am a bit stuck here. Any GATK tool I try (v3.5 and v3.7) that autocreates an index (e.g. ValidateVariants) fails in doing so with the following message:
MESSAGE: I/O error loading or writing tribble index file
However GATK correctly creates the vcf files (for example with UnifiedGenotyper) in the same folder.
I tried:

  • Manually creating/deleting/editing files in the same folder: No problem
  • All folders have complete rw permissions for all users
  • Copying the vcf file to a local drive and running ValidateVariants there correctly creates index file
  • After the error message, the idx file exists but is empty
  • Trying with different vcf files shows the same problem
  • Both the GATK.jar and reference files are local, only the vcf file is on a mounted drive

So in summary, somehow GATK does not like my mounted drives, but only for creating indexes. I am on ubuntu 16.04. Will check source code now.

Issue · Github
by Sheila

Issue Number
2028
State
closed
Last Updated
Assignee
Array
Milestone
Array
Closed By
chandrans

Best Answer

Answers

  • olingercolingerc LuxembourgMember

    Update:
    Creating index with igvtools on mounted drive works, but then GATK gives me the wollowing warning:
    INFO 09:42:58,319 RMDTrackBuilder - Writing Tribble index to disk for file /mnt/files-bioseq/bioseq-temporary/christophe/variants.vcf.idx WARN 09:42:58,347 RMDTrackBuilder - Unable to update index with the sequence dictionary for file /mnt/files-bioseq/bioseq-temporary/christophe/variants.vcf.idx; this will not affect your run of the GATK

  • olingercolingerc LuxembourgMember

    Update:
    Using DEBUG log level I get the following 2 lines just before the error:
    DEBUG 09:52:23,957 RMDTrackBuilder - Creating Tribble index in memory for file /mnt/files-bioseq/bioseq-temporary/christophe/variants.vcf INFO 09:52:24,076 RMDTrackBuilder - Writing Tribble index to disk for file /mnt/files-bioseq/bioseq-temporary/christophe/variants.vcf.idx

  • olingercolingerc LuxembourgMember

    Update:
    NFS shares work fine.
    Samba shares (via CIFS) do not work

  • olingercolingerc LuxembourgMember

    Hi Sheila,

    Indeed, that solved the situation. In the meantime I have moved to NFS shares so the problem was resolved in another way. However, good to know that there is a workaround for cifs shares.

Sign In or Register to comment.