How to run MuTect v1 in Queue?

riederrieder InnsbruckMember

Hello,

I'm trying to set up a queue script that runs MuTect v1 in parallel in scatter/gather mode combined with SGE. I'm using Queue-3.7 and my test script runs in dry-run mode, however when launching it for real scatters are created and submitted to SGE but all of them fail with the following error:

ERROR ------------------------------------------------------------------------------------------
ERROR A USER ERROR has occurred (version 3.7-0-gcfedb67):
ERROR
ERROR This means that one or more arguments or inputs in your command are incorrect.
ERROR The error message below tells you what is the problem.
ERROR
ERROR If the problem is an invalid argument, please check the online documentation guide
ERROR (or rerun your command with --help) to view allowable command-line arguments for this tool.
ERROR
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions https://software.broadinstitute.org/gatk
ERROR
ERROR Please do NOT post this error to the GATK forum unless you have really tried to fix it yourself.
ERROR
ERROR MESSAGE: Invalid command line: Malformed walker argument: Could not find walker with name: MuTect
ERROR ------------------------------------------------------------------------------------------

It seems that the MuTect walker can not be found. I'm importing the following classes:

import org.broadinstitute.gatk.queue.QScript
import org.broadinstitute.gatk.queue.extensions.gatk._
import org.broadinstitute.gatk.queue.extensions.cancer.MuTect
import org.broadinstitute.gatk.queue.util.QScriptUtils
import java.io.File

Can someone tell me what I'm doing wrong?

Thanks
Dietmar

Issue · Github
by Sheila

Issue Number
2011
State
closed
Last Updated
Assignee
Array
Milestone
Array
Closed By
chandrans

Best Answer

Answers

Sign In or Register to comment.