Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Memory setting issue in CNV calling pipeline step 2: SVAltAlign

Anduran_WGSAnduran_WGS HoustonMember

Hello,

I failed in running CNV calling step 2: SVAltAlign, probably because of the memory setting issue.
Even though the "-lsfMemLimit 128" is specified in the command, which is:

"java -Xmx128g -cp ${classpath} \
org.broadinstitute.gatk.queue.QCommandLine \
-S ${SV_DIR}/qscript/SVAltAlign.q \
-S ${SV_DIR}/qscript/SVQScript.q \
-cp ${classpath} \
-gatk ${SV_DIR}/lib/gatk/GenomeAnalysisTK.jar \
-configFile ${SV_DIR}/conf/genstrip_parameters.txt \
-genomeMaskFile ${cwd}/Homo_sapiens_assembly38.mask.101.fasta \
-vcf ${vcf} \
-R ${ref} \
-I ${bam_list} \
-md ${metadata_dir} \
-jobLogDir ${log_dir} \
**-lsfMemLimit 128 **
-run"

The error message is:

"ERROR 16:28:28,640 FunctionEdge - Error: 'java' '-Xmx2048m' '-XX:+UseParallelOldGC' '-XX:ParallelGCThreads=4' '-XX:GCTimeLimit=50' '-XX:GCHeapFreeLimit=10'
...
INFO 16:28:28,710 QGraph - 35 Pend, 0 Run, 1 Fail, 3 Done"

It seems the "-lsfMemLimit 128" parameter is not passed to java command, which is still "-Xmx2048".

How could I fix this issue?

Thanks!
best,
Peter

Issue · Github
by Sheila

Issue Number
1999
State
closed
Last Updated
Assignee
Array
Milestone
Array
Closed By
vdauwera

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hi Peter, I've moved your question to the GenomeStrip forum since this is not our domain. @bhandsaker may be able to help you.

  • bhandsakerbhandsaker Member, Broadie, Moderator admin

    Two responses:
    First, with modern sequencing data you should not be using SVAltAlign, there is no need for this step. Consider it deprecated.
    Second, your specific question is about -lsfMemLimit. This controls the total memory request to LSF for your job. If you want to increase the maximum java heap size, use -memLimit.
    Also note that -lsfMemLimit only applies to LSF7. If you are not using LSF7, use -jobNative to control your job settings such as memory reservation if you need to override the defaults.

Sign In or Register to comment.