DepthOfCoverage takes many hours to run

I am using DepthOfCoverage on a targeted sequencing bam of 400 mbs, reading from hg19 (3 gbs), with an Intel core i3 2.0 ghz processor and 4 gbs of RAM. The remaining hours for completion are almost 60. How should I upgrade my system in order to make it run considerably faster ? My total file list is over 100 BAMs.

Answers

  • shleeshlee CambridgeMember, Broadie, Moderator

    Hi @ceruleanivy,

    Instead of upgrading your system, consider taking your analyses to the cloud. Please see this blogpost for one example appoach. Additionally, perhaps you can run the tool only on regions you care about, e.g. using -L to pass in an intervals list. I'm not a specs person, so perhaps someone else will chime in to comment on your setup.

  • @shlee said:
    Hi @ceruleanivy,

    Instead of upgrading your system, consider taking your analyses to the cloud. Please see this blogpost for one example appoach. Additionally, perhaps you can run the tool only on regions you care about, e.g. using -L to pass in an intervals list. I'm not a specs person, so perhaps someone else will chime in to comment on your setup.

    Thanks shlee, Google cloud seems like a viable solution in order to save time and money upgrading. I was a little bit astonished because this is the first time I encounter computation time problems in bioinformatics, given the fact that I typically handle algorithms and code that run on below average machines. Although my bams cover a considerably smaller region compared to a typical WGS run (I have nearly 300 amplicons at -200bp each) I would like to know if I can pass my bed file (containing the intervals) through the '-L' command, as the guide doesn't give information on the input files of that parameter.

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @ceruleanivy
    Hi,

    Yes, you can use a bed file with -L. Have a look at this document.

    -Sheila

Sign In or Register to comment.