Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

haplotypecaller keeps crashing with OutOfMemory exception during -ERC GVCF mode

thchungthchung SingaporeMember

Hi,

HC keeps crashing with java.lang.OutOfMemoryError for some samples not all of them during -ERC GVCF mode.
I tried 5 samples but only two of them crashed.
I've tried different heap sizes (like 8G, 16G) or even without heap size and different thread numbers (like 8, 2) in vain.
Can you recommend how to avoid this?
I use GATK version 3.6-0-g89b7209 and here is the example command I tried:

java -jar GenomeAnalysisTK.jar -T HaplotypeCaller -nct 16 -R /home/thchung/Data/NGSLibrary/iGenome/Homo_sapiens/UCSC/hg19/Sequence/WholeGenomeFasta/genome.fa -I /home/thchung/Test/FLAM76/indel_realigned_recal.bam --dbsnp /home/thchung/Data/NGSLibrary/GATKBundle/dbsnp_138.hg19.vcf -stand_call_conf 20.0 -stand_emit_conf 20.0 -ERC GVCF -o /home/thchung/Test/Variant/FLAM76_haplotypecaller.g.vcf

The GATK generated log ends like this:

...
INFO 21:26:48,614 ProgressMeter - chr2:201130386 2.49267192E8 6.6 h 95.0 s 14.5% 45.2 h 38.6 h
INFO 21:31:44,791 ProgressMeter - chr2:201130388 2.49267192E8 6.7 h 96.0 s 14.5% 45.8 h 39.1 h
INFO 21:33:45,069 ProgressMeter - chr2:201130388 2.49267192E8 6.7 h 96.0 s 14.5% 46.0 h 39.3 h
INFO 21:41:38,830 ProgressMeter - chr2:201130464 2.49267192E8 6.8 h 98.0 s 14.5% 46.9 h 40.1 h
INFO 21:45:12,246 ProgressMeter - chr2:201130674 2.49267192E8 6.9 h 99.0 s 14.5% 47.3 h 40.5 h

ERROR ------------------------------------------------------------------------------------------
ERROR A USER ERROR has occurred (version 3.6-0-g89b7209):
ERROR
ERROR This means that one or more arguments or inputs in your command are incorrect.
ERROR The error message below tells you what is the problem.
ERROR
ERROR If the problem is an invalid argument, please check the online documentation guide
ERROR (or rerun your command with --help) to view allowable command-line arguments for this tool.
ERROR
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions https://www.broadinstitute.org/gatk
ERROR
ERROR Please do NOT post this error to the GATK forum unless you have really tried to fix it yourself.
ERROR
ERROR MESSAGE: An error occurred because you did not provide enough memory to run this program. You can use the -Xmx argument (before the -jar argument) to adjust the maximum heap size provided to Java. Note that this is a JVM argument, not a GATK argument.
ERROR ------------------------------------------------------------------------------------------

Answers

Sign In or Register to comment.