Our documentation websites are currently offline due to a data center fire. We do not yet have an ETA for restoring service; we’ll update this message when we know more.

mutect-1.1.7 stack error

ncamardancamarda DFCIMember, Broadie

I was looking at this post because it appeared to have the same problem that I am having http://gatkforums.broadinstitute.org/gatk/discussion/6054/stack-error-when-run-mutect-the-first-time ; however, the fix that was mentioned is to download mutect-1.1.7, which I am currently using and gives me this same error.

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

java.lang.ExceptionInInitializerError
at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.(GenomeAnalysisEngine.java:167)
at org.broadinstitute.sting.gatk.CommandLineExecutable.(CommandLineExecutable.java:57)
at org.broadinstitute.sting.gatk.CommandLineGATK.(CommandLineGATK.java:66)
at org.broadinstitute.sting.gatk.CommandLineGATK.main(CommandLineGATK.java:106)
Caused by: java.lang.NullPointerException
at org.reflections.Reflections.scan(Reflections.java:220)
at org.reflections.Reflections.scan(Reflections.java:166)
at org.reflections.Reflections.(Reflections.java:94)
at org.broadinstitute.sting.utils.classloader.PluginManager.(PluginManager.java:79)
... 4 more

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 3.1-0-g72492bb):
ERROR
ERROR This might be a bug. Please check the documentation guide to see if this is a known problem.
ERROR If not, please post the error message, with stack trace, to the GATK forum.
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions http://www.broadinstitute.org/gatk
ERROR
ERROR MESSAGE: Code exception (see stack trace for error itself)
ERROR ------------------------------------------------------------------------------------------

In fact, simply running "java -jar mutect-1.1.7.jar" gives me this error. My java version details are here:
java -version
java version "1.8.0_91"
Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.91-b14, mixed mode)

Please advise! Thank you for your help.

Best Answer

Answers

  • ncamardancamarda DFCIMember, Broadie

    Thank you for your FAST reply, Geraldine! I will try your solution and then get back to you. Thanks.

  • zhaoming159753zhaoming159753 Shanghai, ChinaMember

    I get the same error when i use java 1.7

    module list
    Currently Loaded Modulefiles:
    1) jdk/1.7

    java -jar mutect-1.1.7.jar

    ERROR ------------------------------------------------------------------------------------------
    ERROR stack trace

    java.lang.ExceptionInInitializerError
    at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.(GenomeAnalysisEngine.java:167)
    at org.broadinstitute.sting.gatk.CommandLineExecutable.(CommandLineExecutable.java:57)
    at org.broadinstitute.sting.gatk.CommandLineGATK.(CommandLineGATK.java:66)
    at org.broadinstitute.sting.gatk.CommandLineGATK.main(CommandLineGATK.java:106)
    Caused by: java.lang.NullPointerException
    at org.reflections.Reflections.scan(Reflections.java:220)
    at org.reflections.Reflections.scan(Reflections.java:166)
    at org.reflections.Reflections.(Reflections.java:94)
    at org.broadinstitute.sting.utils.classloader.PluginManager.(PluginManager.java:79)
    ... 4 more

    ERROR ------------------------------------------------------------------------------------------
    ERROR A GATK RUNTIME ERROR has occurred (version 3.1-0-g72492bb):
    ERROR
    ERROR This might be a bug. Please check the documentation guide to see if this is a known problem.
    ERROR If not, please post the error message, with stack trace, to the GATK forum.
    ERROR Visit our website and forum for extensive documentation and answers to
    ERROR commonly asked questions http://www.broadinstitute.org/gatk
    ERROR
    ERROR MESSAGE: Code exception (see stack trace for error itself)
    ERROR ------------------------------------------------------------------------------------------
  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie
    @zhaoming159753 Are you sure that's the Java version called by the system? What happens when you run java -version?
  • jgxjgx North CarolinaMember

    Please reduce the memory to 16G or less, and use the java default used by the system. it will work!!

Sign In or Register to comment.