The current GATK version is 3.8-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!

You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Got a problem?

1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?

Then follow instructions in Article#1894.

Formatting tip!

Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Download the latest Picard release at
GATK version 4.beta.3 (i.e. the third beta release) is out. See the GATK4 beta page for download and details.

MarkDuplicates---“did not start with a parseable number”

I was running RNA-seq data through the MarkDuplicates in Picard package for SNP calling getting the message:

WARNING 2016-08-31 16:48:12 AbstractOpticalDuplicateFinderCommandLineProgram A field field parsed out of a read name was expected to contain an integer and did not. Read name: SN1001:449:HGTN3ADXX:1:2115:4606:89966:R2#1#CTCCT. Cause: String 'R2#1#CTCCT' did not start with a parsable number.

Then I run the command:

samtools view resources/HepG2.RBFOX2/HepG2.RBFOX2.rep2.R2.tag.uniq.sorted.bam | grep R2#1#CTCCT

And I got this:

SN1001:449:HGTN3ADXX:2:2110:11231:12370:R2#1#CTCCT 16 chrX 133035777 37 31M * 0 0 TTTTTGAGTTAAAGTTATACACCTGAAGAGG BFFBFB

So I tried to run the command ValidateSamFile

ERROR: Record 2243391, Read name SN1001:449:HGTN3ADXX:1:1207:18758:88057:R2#2#TATAT, NM tag (nucleotide differences) in file [2] does not match reality [6]
ERROR: Record 2500598, Read name SN1001:449:HGTN3ADXX:2:1206:6729:26515:R2#1#TAATC, NM tag (nucleotide differences) in file [3] does not match reality [7]
ERROR: Record 2500599, Read name SN1001:449:HGTN3ADXX:2:2110:7481:90889:R2#1#TTCAG, NM tag (nucleotide differences) in file [3] does not match reality [8]
ERROR: Record 2500601, Read name SN1001:449:HGTN3ADXX:1:1210:6384:54132:R2#1#TAGAT, NM tag (nucleotide differences) in file [3] does not match reality [9]
ERROR: Record 2500602, Read name SN1001:449:HGTN3ADXX:2:2111:15383:87620:R2#1#GGGGG, NM tag (nucleotide differences) in file [3] does not match reality [9]
ERROR: Record 2500603, Read name SN1001:449:HGTN3ADXX:2:2212:9564:100522:R2#1#GGCGC, NM tag (nucleotide differences) in file [3] does not match reality [10]
ERROR: Record 2500604, Read name SN1001:449:HGTN3ADXX:1:2110:14050:67425:R2#1#GGCCC, NM tag (nucleotide differences) in file [2] does not match reality [9]
ERROR: Record 2500605, Read name SN1001:449:HGTN3ADXX:1:2205:20926:12488:R2#1#TCCCC, NM tag (nucleotide differences) in file [1] does not match reality [3]
ERROR: Record 2500606, Read name SN1001:449:HGTN3ADXX:2:2109:8561:77192:R2#1#CCCCC, NM tag (nucleotide differences) in file [1] does not match reality [3]

Does this warning message matters?


  • zillurbmb51zillurbmb51 USAMember
    edited May 17

    Hi there,
    I have the same problem. I tried with ValidateSamFile and getting the following:

    [zillur@genomics pberghei]$ java -jar /gondor/zillur/tools/picard.jar ValidateSamFile I=SRR1858992_gca.sorted.bam MODE=SUMMARY
    [Tue May 16 12:55:00 EDT 2017] Executing as zillur@genomics on Linux 3.10.0-514.16.1.el7.x86_64 amd64; OpenJDK 64-Bit Server VM 1.8.0_131-b11; Picard version: 2.9.0-1-gf5b9f50-SNAPSHOT
    [Tue May 16 12:55:14 EDT 2017] picard.sam.ValidateSamFile done. Elapsed time: 0.25 minutes.
    To get help, see
    Exception in thread "main" htsjdk.samtools.SAMException: /tmp/zillur/CSPI.1880274338990258510.tmp/5847.tmpnot found
        at htsjdk.samtools.util.FileAppendStreamLRUCache$Functor.makeValue(
        at htsjdk.samtools.util.FileAppendStreamLRUCache$Functor.makeValue(
        at htsjdk.samtools.util.ResourceLimitedMap.get(
        at htsjdk.samtools.CoordinateSortedPairInfoMap.getOutputStreamForSequence(
        at htsjdk.samtools.CoordinateSortedPairInfoMap.put(
        at htsjdk.samtools.SamFileValidator$CoordinateSortedPairEndInfoMap.put(
        at htsjdk.samtools.SamFileValidator.validateMateFields(
        at htsjdk.samtools.SamFileValidator.validateSamRecordsAndQualityFormat(
        at htsjdk.samtools.SamFileValidator.validateSamFile(
        at htsjdk.samtools.SamFileValidator.validateSamFileSummary(
        at picard.sam.ValidateSamFile.doWork(
        at picard.cmdline.CommandLineProgram.instanceMain(
        at picard.cmdline.PicardCommandLine.instanceMain(
        at picard.cmdline.PicardCommandLine.main(
    Caused by: /tmp/zillur/CSPI.1880274338990258510.tmp/5847.tmp (Too many open files)
        at Method)
        at htsjdk.samtools.util.FileAppendStreamLRUCache$Functor.makeValue(
        ... 13 more

    What does it mean? The problem still persists. Thanks in advance. Waiting for your suggestions.

    Best regards

    Post edited by shlee on
Sign In or Register to comment.