Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

FastaAlternateReferenceMaker leaving out verified SNPs from FASTA file

I have Illlumina sequenced genomes that I have aligned using BWA and GATK to a section of a genome that I am interested in. When I examine the .bam file and the VCF file generated in IGV I can clearly see a single T in the middle of the sequence (which is an incredibly important location for the protein function)

However, when I run the FastaAlternateReferenceMaker on it as such:
java -Xmx4G -Djava.io.tmpdir=$tempdir -jar $GA -R $Tgindex -T VariantFiltration --variant CTG.ROP38.raw.snps.indels.vcf -filter "QD < 2.0" -filterName "SNP_filter" -o CTG.ROP38.snps.filter.vcf
java -Xmx4G -Djava.io.tmpdir=$tempdir -jar $GA -R $Tgindex -T SelectVariants --variant CTG.ROP38.snps.filter.vcf -o CTG.ROP38.snps.select.vcf -env -ef
java -Xmx4G -Djava.io.tmpdir=$tempdir -jar $GA -R $Tgindex -T FastaAlternateReferenceMaker --variant CTG.ROP38.snps.select.vcf -o CTG.ROP38.raw.snps.indels.vcf_071516.fasta

I do not get the T in my sequence, even though the SNP has a PASS in the FILTER column
VCF at 5070:
TGME49_242110 5070 . A T, 3024.77 PASS DP=75;MLEAC=2,0;MLEAF=1.00,0.00;MQ=60.00 GT:AD:DP:GQ:PL:SB 1/1:0,75,0:75:99:3053,225,0,3053,225,3053:0,0,45,30


I don't understand why I'm not getting the appropriate SNP from this VCF as this process has worked well for me in the past. Please help.

Sign In or Register to comment.