If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.
We will be out of the office on November 11th and 13th 2019, due to the U.S. holiday(Veteran's day) and due to a team event(Nov 13th). We will return to monitoring the GATK forum on November 12th and 14th respectively. Thank you for your patience.

Indel Realignment stops but gives no error

fuad193fuad193 IsraelMember


It's not the first time I run NEXT-seq pipeline on fastq files. It works for me several times and I never got a problem. But it's only one sample which drives me crazy because during the indel realignment via GATK, the processes ends in chromosome 9 but gives no error, here is the tail of the log

INFO  10:57:36,310 ProgressMeter -      7:57136589   3.7736356E7    16.5 m      26.0 s       41.7%    39.6 m      23.1 m 
INFO  10:58:06,312 ProgressMeter -      7:94166979   3.8936404E7    17.0 m      26.0 s       42.9%    39.6 m      22.6 m 
INFO  10:58:36,313 ProgressMeter -     7:116838457   3.9836497E7    17.5 m      26.0 s       43.6%    40.1 m      22.6 m 
INFO  10:59:06,315 ProgressMeter -     7:152055822   4.1036547E7    18.0 m      26.0 s       44.8%    40.2 m      22.2 m 
INFO  10:59:36,316 ProgressMeter -      8:31716097   4.2233863E7    18.5 m      26.0 s       46.0%    40.2 m      21.7 m 
INFO  11:00:06,423 ProgressMeter -      8:85353783   4.3434018E7    19.0 m      26.0 s       47.7%    39.8 m      20.8 m 
INFO  11:00:36,425 ProgressMeter -     8:104075325   4.4434162E7    19.5 m      26.0 s       48.4%    40.3 m      20.8 m 
INFO  11:01:06,426 ProgressMeter -       9:6600457   4.5663137E7    20.0 m      26.0 s       49.9%    40.1 m      20.1 m 
INFO  11:01:36,428 ProgressMeter -      9:67965301   4.6863186E7    20.5 m      26.0 s       51.9%    39.5 m      19.0 m 
INFO  11:02:04,323 GATKRunReport - Uploaded run statistics report to AWS S3 

Of course the out bam file here is truncated at chromosome 9, but the input sorted bam file isn't. Also the indel target interval which was created in the previous step via GATK RealignerTargetCreator include all chromosomes not just the first 9. How do I solve this problem ? I tried re-aligning reads and reprocess it several time but nothing change I keep getting a truncation. It's only happening with this sample.

Here is my command

nohup /usr/bin/jre1.7.0_51/bin/java -jar /usr/bin/GenomeAnalysisTK.jar -T IndelRealigner --log_to_file families/BP/log/$filename.indelrealigner.log -I families/BP/bam/$filename.dedup.bam -R $maindir/genome/hg19.fa -targetIntervals families/BP/bam/$filename.target_intervals.list -o families/BP/bam/$filename.realigned.bam -known $maindir/databases/Mills_and_1000G_gold_standard.indels.hg19.vcf &



  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin
    Sorry to hear you're having so much trouble. Please run ValidateSamFile on the input bam in summary mode and post the result here. That will tell us if there's anything wrong with the input bam itself.
Sign In or Register to comment.