Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.
Attention:
We will be out of the office for a Broad Institute event from Dec 10th to Dec 11th 2019. We will be back to monitor the GATK forum on Dec 12th 2019. In the meantime we encourage you to help out other community members with their queries.
Thank you for your patience!

Having problem with VQSR step

AzlinAzlin Member
edited June 2016 in Ask the GATK team

Hi there.

I'm Lynn, doing the whole genome sequencing for human. I'm currently using GATK for variant call and now having problems for VQSR step.

Here is the command I entered:
[email protected]:/media/promise/storage/Tools/Softwares/GenomeAnalysisTK-3.4-0$ java -Xmx4g -jar GenomeAnalysisTK.jar -T VariantRecalibrator -R /media/promise/storage/References/Referance/GATK\ Bundle/hg19/ucsc.hg19.fasta -input /media/promise/storage/Postgrad/Deep\ and\ median\ coverage/Re-run\ phasing/Deep\ coverage/SM19/SM19.bam.vcf -resource:hapmap,known=false,training=true,truth=true,prior=15.0 /media/promise/storage/References/Referance/GATK\ Bundle/hg19/hapmap_3.3.hg19.vcf -resource:omni,known=false,training=true,truth=true,prior=12.0 /media/promise/storage/References/Referance/GATK\ Bundle/hg19/2.8/1000G_omni2.5.hg19.sites.vcf -resource:1000G,known=false,training=true,truth=false,prior=10.0 /media/promise/storage/References/Referance/GATK\ Bundle/hg19/2.8/1000G_phase1.snps.high_confidence.hg19.sites.vcf -resource:dbsnp,known=true,training=false,truth=false,prior=2.0 /media/promise/storage/References/Referance/GATK\ Bundle/hg19/2.8/dbsnp_138.hg19.vcf -an QD -an MQRankSum -an ReadPosRanksum -an FS -an DP -mode SNP -recalFile /media/promise/storage/Postgrad/Deep\ and\ median\ coverage/Re-run\ phasing/Deep\ coverage/SM19/SM19_snp.recal -tranchesFile /media/promise/storage/Postgrad/Deep\ and\ median\ coverage/Re-run\ phasing/Deep\ coverage/SM19/SM19_snp.tranches -rscriptFile /media/promise/storage/Postgrad/Deep\ and\ median\ coverage/Re-run\ phasing/Deep\ coverage/SM19/SM19_snp.plots.R

It initially run smoothly but then the error appeared:

ERROR ------------------------------------------------------------------------------------------
ERROR A USER ERROR has occurred (version 3.4-0-g7e26428):
ERROR
ERROR This means that one or more arguments or inputs in your command are incorrect.
ERROR The error message below tells you what is the problem.
ERROR
ERROR If the problem is an invalid argument, please check the online documentation guide
ERROR (or rerun your command with --help) to view allowable command-line arguments for this tool.
ERROR
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions http://www.broadinstitute.org/gatk
ERROR
ERROR Please do NOT post this error to the GATK forum unless you have really tried to fix it yourself.
ERROR
ERROR MESSAGE: Bad input: Values for ReadPosRanksum annotation not detected for ANY training variant in the input callset. VariantAnnotator may be used to add these annotations. See http://gatkforums.broadinstitute.org/discussion/49/using-variant-annotator
ERROR ------------------------------------------------------------------------------------------

I've tried to find the answer from the forums but I'm not really understand on what should I do with to fix this error. Could anyone please help me?

Thank you in advance!
Lynn.

Tagged:

Best Answer

Answers

Sign In or Register to comment.