To celebrate the release of GATK 4.0, we are giving away free credits for running the GATK4 Best Practices pipelines in FireCloud, our secure online analysis portal. It’s first come first serve, so sign up now to claim your free credits worth $250. Sponsored by Google Cloud. Learn more at https://software.broadinstitute.org/firecloud/documentation/freecredits

fixmisencoded quality scores for combination of correct and incorrect encoding

When I rand Mutect on a .bam file for tumor and normal sequences, I received an error message about incorrectly encoded quality scores, so I applied the --fixencodedqualityscores and re-ran Mutect. This time, I'm getting an error message:

Bad input: while fixing mis-encoded base qualities we encountered a read that was correctly encoded; we cannot handle such  a mixture of reads so unfortunately the BAM must be fixed with some other tool

Evidently, this is because one of the files (control) was correctly encoded while the other (tumor, which I had to realign) was not. Is there a flag I can use to tell Mutect to only apply the quality scores fix to one of the files while running? Otherwise, there is an entire set of control .bams that I'll need to realign just to correct this problem.

Best Answer

Answers

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @max_shpak
    Hi,

    I don't think there is a flag in MuTect2 to do what you are asking. You can run PrintReads with the --fixencodedqualityscores flag on just the tumor BAM to fix the quality scores. However, did you follow the Best Practices pre-processing steps? If you did, you should not be running into this error at this step.

    -Sheila

Sign In or Register to comment.