Hi GATK Users,

Happy Thanksgiving!
Our staff will be observing the holiday and will be unavailable from 22nd to 25th November. This will cause a delay in reaching out to you and answering your questions immediately. Rest assured we will get back to it on Monday November 26th. We are grateful for your support and patience.
Have a great holiday everyone!!!

GATK Staff

BaseRecalibrator Unknown index type

tiffytiffy AustriaMember


I am trying to run BaseRecalibrator on my realigned files using GATK v3.5-0 and the following command

java -jar GenomeAnalysisTK.jar -T BaseRecalibrator -R reference.fasta -I realign.bam -knownSites known_snps.vcf -o data.table

but I am getting this error message "ERROR MESSAGE: Unknown index type. magic number: 0x0; type 0".
Any idea what could be wrong?

Thank you very much for your help,


  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    Hi Susanne,

    It seems like an issue with one of your indices. Can you try deleting the FASTA index and BAM index and re-generating them?

    Can you also try validating your BAM file using Picard's ValidateSamFile.


  • tiffytiffy AustriaMember

    Hi Sheila,
    I have deleted and regenerated both the FASTA index and BAM index (using samtools 1.3) and I have validated the realign.bam file using Picard. The bam file seems fine (also all previous GATK steps finished without an error). I have tried rerunning BaseRecalibrator but unfortunately, I am still receiving the same error message.

  • tiffytiffy AustriaMember

    Hi again,

    I found the issue: the cluster I was running the job on has a java 1.7 as default. Everything works well with java 1.8.

    Thanks for your help,

    Issue · Github
    by Sheila

    Issue Number
    Last Updated
  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    Hi Susanne,

    Hold on! GATK is not yet supporting Java 1.8. In your case, just because the tool is not crashing with Java 1.8, it does not mean the tool is working :confused:. The tools may run with Java 1.8, but the order of some lists are different between the two versions. So, the calculations that depend on list order will give different results between the two Java versions. I am asking the team to weigh in on your original error from Java 1.7. I will get back to you soon.


  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    @tiffy Don't trust the results of your jobs run on Java 1.8. They may be wrong. You have to fix whatever is preventing you from running on Java 1.7. Check that you're using the Oracle Java and not OpenJDK, because the latter is not supported.

Sign In or Register to comment.