MuTect2 Empty vcf file even with tumor/normal pair input

visivasvisivas Cambridge, MAMember

Hi I am aware of a bug in MuTect2 that gives an empty vcf file when generating PON. However I am experiencing the same issue when using tumor/normal pair mode as well. The log file indicates a "Ran local assembly on 0 active regions" error. The only different aspect of my dataset is that I am looking at only 3 amplicons on three different locations in human. Does this have an impact of how MuTect2 works?

Thanks
Siva

Tagged:

Best Answer

Answers

  • visivasvisivas Cambridge, MAMember

    After looking at IGV it seems that at least some kind of deletion should have been called (even with a REJECT filter) in some locations. The deletion is surely at a low allelic fraction (4%) and has some neighboring gap events, but based on my previous experience with MuTect these would have been called with a REJECT filter. It is odd that out of the 20 libraries I ran through MuTect none of them came out with any SNV or Indel.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Out of curiosity, have you tried running the old MuTect on this data? You can also try running HaplotypeCaller and see if it finds any active regions. These two tests will tell us whether there may be something wrong with the data or with Mutect2.

    Be sure to also look at the filtering summary in the log. It will tell you whether a large proportion of reads were filtered out, which is one possible cause for what you're observing.

  • visivasvisivas Cambridge, MAMember

    Hi Geraldine, Yes I have tried old MuTect and that also did not give any SNVs. Also, I did use HaplotypeCaller and same result with no active regions found. The log files indicate that a small proportion of reads were filtered out <1% but most were retained. Only the UnifiedGenotyper gave a couple of SNPs but no Indels. I think you are right that there are actually no variants.
    But just out of curiosity, how can you rule out that this is not a bug related to the other one with generating PON?

    Thanks a lot

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @visivas
    Hi,

    If both HaplotypeCaller and the original Mutect are not giving you variants in the region, it must not be an issue with MuTect2. Note that HaplotypeCaller shows "no active regions found". This means there is no reason for the tools to suspect there is variation at any of the sites. Have you checked the quality of the bases? Perhaps they are not good.

    I hope this makes sense.

    -Sheila

Sign In or Register to comment.