problem with Base Recalibrator tool

nayshoolnayshool israelMember

Hi everyone,

I am trying to use Base Recalibrator tool using the following command:
java -jar /home/gen-bioinf/Desktop/data/NGSanalysis/Tools/GenomeAnalysisTK-3.5/GenomeAnalysisTK.jar -T BaseRecalibrator -R /home/gen-bioinf/Desktop/data/NGSanalysis/Bundle/Homo_sapiens_assembly38.fasta -I result_RG_dedup_realignedBAM.bam -L 20 -knownSites /home/gen-bioinf/Desktop/data/NGSanalysis/Bundle/dbsnp_144.hg38.vcf -knownSites /home/gen-bioinf/Desktop/data/NGSanalysis/Bundle/Mills_and_1000G_gold_standard.indels.hg38.vcf -o recal.table

but it's giving me this message:
NFO 17:47:23,910 HelpFormatter - -------------------------------------------------------------------------------- INFO 17:47:23,912 HelpFormatter - The Genome Analysis Toolkit (GATK) v3.5-0-g36282e4, Compiled 2015/11/25 04:03:56 INFO 17:47:23,912 HelpFormatter - Copyright (c) 2010 The Broad Institute INFO 17:47:23,912 HelpFormatter - For support and documentation go to http://www.broadinstitute.org/gatk INFO 17:47:23,916 HelpFormatter - Program Args: -T BaseRecalibrator -R /home/gen-bioinf/Desktop/data/NGSanalysis/Bundle/Homo_sapiens_assembly38.fasta -I result_RG_dedup_realignedBAM.bam -L 20 -knownSites /home/gen-bioinf/Desktop/data/NGSanalysis/Bundle/dbsnp_144.hg38.vcf -knownSites /home/gen-bioinf/Desktop/data/NGSanalysis/Bundle/Mills_and_1000G_gold_standard.indels.hg38.vcf -o recal.table INFO 17:47:23,920 HelpFormatter - Executing as [email protected] on Linux 3.13.0-79-generic amd64; Java HotSpot(TM) 64-Bit Server VM 1.8.0_73-b02. INFO 17:47:23,921 HelpFormatter - Date/Time: 2016/03/13 17:47:23 INFO 17:47:23,921 HelpFormatter - -------------------------------------------------------------------------------- INFO 17:47:23,921 HelpFormatter - -------------------------------------------------------------------------------- INFO 17:47:24,386 GenomeAnalysisEngine - Strictness is SILENT INFO 17:47:24,608 GenomeAnalysisEngine - Downsampling Settings: No downsampling INFO 17:47:24,617 SAMDataSource$SAMReaders - Initializing SAMRecords in serial INFO 17:47:24,749 SAMDataSource$SAMReaders - Done initializing BAM readers: total time 0.13

Followed by this wired long error:
hrUn_JTFH01000133v1_decoy, chrUn_JTFH01000134v1_decoy, chrUn_JTFH01000135v1_decoy, chrUn_JTFH01000136v1_decoy, chrUn_JTFH01000137v1_decoy, chrUn_JTFH01000138v1_decoy, chrUn_JTFH01000139v1_decoy, chrUn_JTFH01000140v1_decoy, chrUn_JTFH01000141v1_decoy, chrUn_JTFH01000142v1_decoy, chrUn_JTFH01000143v1_decoy, chrUn_JTFH01000144v1_decoy, chrUn_JTFH01000145v1_decoy, chrUn_JTFH01000146v1_decoy, chrUn_JTFH01000147v1_decoy, chrUn_JTFH01000148v1_decoy, chrUn_JTFH01000149v1_decoy, chrUn_JTFH01000150v1_decoy, chrUn_JTFH01000151v1_decoy, chrUn_JTFH01000152v1_decoy, chrUn_JTFH01000153v1_decoy, chrUn_JTFH01000154v1_decoy, chrUn_JTFH01000155v1_decoy, chrUn_JTFH01000156v1_decoy, chrUn_JTFH01000157v1_decoy, chrUn_JTFH01000158v1_decoy, chrUn_JTFH01000159v1_decoy, chrUn_JTFH01000160v1_decoy, .... ... ... DQB1*05:01:01:02, HLA-DQB1*05:03:01:01, HLA-DQB1*05:03:01:02, HLA-DQB1*06:01:01, HLA-DQB1*06:02:01, HLA-DQB1*06:03:01, HLA-DQB1*06:09:01, HLA-DRB1*01:01:01, HLA-DRB1*01:02:01, HLA-DRB1*03:01:01:01, HLA-DRB1*03:01:01:02, HLA-DRB1*04:03:01, HLA-DRB1*07:01:01:01, HLA-DRB1*07:01:01:02, HLA-DRB1*08:03:02, HLA-DRB1*09:21, HLA-DRB1*10:01:01, HLA-DRB1*11:01:01, HLA-DRB1*11:01:02, HLA-DRB1*11:04:01, HLA-DRB1*12:01:01, HLA-DRB1*12:17, HLA-DRB1*13:01:01, HLA-DRB1*13:02:01, HLA-DRB1*14:05:01, HLA-DRB1*14:54:01, HLA-DRB1*15:01:01:01, HLA-DRB1*15:01:01:02, HLA-DRB1*15:01:01:03, HLA-DRB1*15:01:01:04, HLA-DRB1*15:02:01, HLA-DRB1*15:03:01:01, HLA-DRB1*15:03:01:02, HLA-DRB1*16:02:01] ##### ERROR ------------------------------------------------------------------------------------------
(I have attached the original terminal output)

what seems to be the problem?

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    That's not the full error, it's just part of your reference sequence dictionary... But it's enough to know what is wrong .

    Try again without the -L 20 bit. While your job runs, look up what -L does.

Sign In or Register to comment.