To celebrate the release of GATK 4.0, we are giving away free credits for running the GATK4 Best Practices pipelines in FireCloud, our secure online analysis portal. It’s first come first serve, so sign up now to claim your free credits worth $250. Sponsored by Google Cloud. Learn more at https://software.broadinstitute.org/firecloud/documentation/freecredits

Leftover "--allowNonOverlappingCommandLineSamples" in SelectVariants?

Hi guys,
I was subsetting a VCF file with SelectVariants, based on a sample list which contains some additional samples we didn't sequence.

GATK SelectVariants complained about the samples missing from VCF file and the suggested:

##### ERROR 
##### ERROR To ignore these samples, run with --allowNonOverlappingCommandLineSamples

However, I followed the suggestion and got

  ##### ERROR Please do NOT post this error to the GATK forum unless you have really tried to fix it yourself.
  ##### ERROR
  ##### ERROR MESSAGE: Argument with name 'allowNonOverlappingCommandLineSamples' isn't defined.

I can obviously fix this myself as recommended :) but I thought the option was quite convenient, and seemed right to flag this message up as the output suggests to use an option apparently not in place anymore (version 3.5-0-g36282e4)

cheers,
F

Tagged:

Best Answer

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie
    Accepted Answer

    Actually the option is still in place but it is in the wrong case in the error message. Try with --ALLOW_NONOVERLAPPING_COMMAND_LINE_SAMPLES instead. We'll fix the error message for the next version.

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie
    Accepted Answer

    Actually the option is still in place but it is in the wrong case in the error message. Try with --ALLOW_NONOVERLAPPING_COMMAND_LINE_SAMPLES instead. We'll fix the error message for the next version.

Sign In or Register to comment.