Running MuTect error Malformed walker argument: Could not find walker with name

morovatuncmorovatunc turkeyMember
edited January 2016 in MuTect v1

Dear all hi,

I am aware that this problem has been posted couple times, however I have not seen a working result for me thats why forgive my ignorance. I have a pair of tumor and normal bam files samples which I am trying to call mutations. Thats why I needed the mutest. I ran the code below.

My java version is java version "1.7.0_79"
Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)

My mutest help command is
Tuncs-MacBook-Pro:muTect-1 morova$ java -jar mutect-1.1.7.jar --help
--------------------------------------------------------------------------------
The Genome Analysis Toolkit (GATK) v3.1-0-g72492bb, Compiled 2015/01/21 17:10:56
Copyright (c) 2010 The Broad Institute
For support and documentation go to http://www.broadinstitute.org/gatk
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
-usage: java -jar mutect-1.1.7.jar -T [-args ] [-I ] [-rbs ] [-et
] [-K ] [-tag ] [-rf ] [-L ] [-XL ] [-isr
] [-im ] [-ip ] [-R ] [-ndrs] [-maxRuntime
] [-maxRuntimeUnits ] [-dt ] [-dfrac ] [-dcov
] [-baq ] [-baqGOP ] [-fixMisencodedQuals]
[-allowPotentiallyMisencodedQuals] [-OQ] [-DBQ ] [-PF ] [-BQSR ] [-DIQ]
[-EOQ] [-preserveQ ] [-globalQScorePrior ] [-S ]
[-rpr] [-kpr] [-sample_rename_mapping_file ] [-U ] [-nt ] [-nct
] [-mte] [-bfh ] [-rgbl ] [-ped
] [-pedString ] [-pedValidationType ] [-variant_index_type
] [-variant_index_parameter ] [-l ] [-log ]
[-h] [-version]

 -T,--analysis_type <analysis_type>                                                      Name of the tool to run
 -args,--arg_file <arg_file>                                                             Reads arguments from the 
                                                                                         specified file
 -I,--input_file <input_file>                                                            Input file containing sequence 
                                                                                         data (SAM or BAM)
 -rbs,--read_buffer_size <read_buffer_size>                                              Number of reads per SAM file to 
                                                                                         buffer in memory
 -et,--phone_home <phone_home>                                                           Run reporting mode (NO_ET|AWS|

...

This is the command that I used for the mutation calling.

$java -jar ~/muTect-1/muTect-1.1.7.jar --analysis_type Mutect --reference_sequence reference/Homo_sapiens_assembly19.fasta --cosmic ~/dbsnp-cosmic/b37_cosmic_v54_120711.vcf --dbsnp ~/dbsnp-cosmic/dbsnp_132_b37.leftAligned.vcf --intervals 17:7577100-7577200 --input_file:normal normal/TCGA-CH-5741-10A-01D-1572_130104_SN1120_0209_BD1KP6ACXX_s_2_rg.sorted.bam --input_file:tumor tumor/TCGA-CH-5741-01A-11D-1572_130104_SN1120_0209_BD1KP6ACXX_s_1_rg.sorted.bam --out mutect_sample.out --coverage_file mutect_sample.wig.txt

There are several thins that I dont understand.
1) Why GATK comes up when I call mutect?
2) I did not quite understand the building up GATK developers kit. It seems like the solution is linked with that step. However, even I clone GATK repo on git hub, this does not help to my solution.

Thank you very much for your help.

Best regards,

Tunc

Best Answer

Answers

  • morovatuncmorovatunc turkeyMember

    Dear Geraldine,

    Thank you for your fast respond. I tried mutect2 like you said. it gave an error about my reference files and it appeared that I dont have reference fast dictiornary. after that I read the FAQ and found out I need to run CreateSequenceDictionary.jar. However, during the instillation of picard. I got a java version error. As you can see from https://github.com/samtools/htsjdk java 8 is required for the installation of picard. However, I dont know if java 8 is ok for mutect2? As a result, i am in a point where If I choose java 8 i fail at mutect and if I java 7 I cannot obtain a required file for mutect2.

    Also, I am trying to use an ensemble approach to combine mutations from different callers( somaticseq) Therefore, somaticseq only takes mutect1 input. Hence, will I get a different formatted output with mutect2 in terms of snp ?

    Thank you for your help.

    Tunc

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @morovatunc
    Hi Tunc,

    I realize this is a late response, but if you use the latest nightly build, Java 1.8 is accepted.

    MuTect2 outputs a proper VCF so you should not have any issue there.

    -Sheila

  • priyatamapriyatama CAMember

    Hi, I am running mutect for my somatic variant analysis. I wonder how can I use the option -sample_rename_mapping_file.
    Is it for rename multiple bam files into one file.
    Should I add below command in my mutest code-
    --input_file:tumor SM1_Lib1.bam
    --input_file:tumor SM1_Lib2.bam
    --sample_rename_mapping_file:tumor SM1.bam

    Similarly, for the matched normal.

    Thanks in advance.````

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @priyatama
    Hi,

    I think this page will help.

    -Sheila

  • priyatamapriyatama CAMember

    Thanks Sheila for your reply. I have gone through this link already but I am not able to run this command successfully. does sample_rename_mapping_file the merge the multiple file and rename it with the given name ?

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @priyatama

    Hi,

    I think it will replace the SM tag in the specified BAM file with the sample name you want.

    What is the exact command you ran, and what is the output you get? Note this line: Each line of the mapping file must contain the absolute path to a BAM file, followed by whitespace, followed by the new sample name for that BAM file.

    -Sheila

Sign In or Register to comment.