We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

AddOrReplaceReadGroups

Hi

I'm using RVboost to perform some RNAseq variant calling. I've done some tophat2 and then using the .bam file I'm using RVboost, but when I use it I get: RNA bam file : accepted_hits_picard.bam doesn't have Read Group Information, Read Group is necessary in the BAM to run the pipeline.

So I tried using picard tools as described below. But RVboost keeps sending me back the same error.
I have seen how the header is changed by adding two lines corresponding to @RG, so everything seems to be going as expected.

java -jar AddOrReplaceReadGroups.jar INPUT=/local/RNAseq_variant/Raw_data/Panc042_PDAC_PRITUM_Px00/FastQ_files__RNASeq_data/tophat_out/accepted_hits.bam OUTPUT=/local/RNAseq_variant/Raw_data/Panc042_PDAC_PRITUM_Px00/FastQ_files__RNASeq_data/tophat_out/accepted_hits_picard.bam RGID=Unknown RGCN=unknown RGDS=unknown RGPI=41 RGPL=illumina RGLB=LaneX RGPU=NONE RGSM=AnySampleName

¿Do you have any clue about if I may be missing something during the the use of AddOrReplaceReadGroups?

Thanks!

Best Answer

Answers

  • Thanks I already solved the problem. it wasn't a problem of AddOrReplaceReadGroups.jar

Sign In or Register to comment.