MuTect2 panel of normals – empty VCF file

Hi,

I have successfully run MuTect2 on many paired tumor/normal samples. However, when I try creating a panel of normals (using the the recommended approach), I end up with empty VCF files.

Here is the tail of the output when running MuTect2 on a normal sample (restricted to chr7 for testing purposes):

INFO 15:02:19,928 ProgressMeter - chr7:159138663 0.0 4.8 h 15250.3 w 100.0% 4.8 h 0.0 s INFO 15:02:29,476 MuTect2 - Ran local assembly on 0 active regions INFO 15:02:29,488 ProgressMeter - done 1.59138663E8 4.8 h 107.0 s 100.0% 4.8 h 0.0 s INFO 15:02:29,490 ProgressMeter - Total runtime 17114.21 secs, 285.24 min, 4.75 hours INFO 15:02:29,492 MicroScheduler - 1997879 reads were filtered out during the traversal out of approximately 6720185 total reads (29.73%) INFO 15:02:29,494 MicroScheduler - -> 0 reads (0.00% of total) failing BadCigarFilter INFO 15:02:29,495 MicroScheduler - -> 1947653 reads (28.98% of total) failing DuplicateReadFilter INFO 15:02:29,497 MicroScheduler - -> 0 reads (0.00% of total) failing FailsVendorQualityCheckFilter INFO 15:02:29,498 MicroScheduler - -> 0 reads (0.00% of total) failing MalformedReadFilter INFO 15:02:29,500 MicroScheduler - -> 0 reads (0.00% of total) failing MappingQualityUnavailableFilter INFO 15:02:29,501 MicroScheduler - -> 19931 reads (0.30% of total) failing NotPrimaryAlignmentFilter INFO 15:02:29,503 MicroScheduler - -> 30295 reads (0.45% of total) failing UnmappedReadFilter

So MuTect2 is actually doing something (but I am not sure what it is). I think the Ran local assembly on 0 active regions part looks rather suspicious.

For completeness, here is the command executed:

java -Xmx16g -Djava.io.tmpdir=tmp -jar GenomeAnalysisTK.jar \ -T MuTect2 \ -nct 16 \ --reference_sequence ucsc.hg19.fasta \ --dbsnp dbsnp_138.hg19.vcf \ --cosmic hg19_cosmic_v54_120711.vcf \ --input_file:tumor test_sample.bam \ --artifact_detection_mode \ -L chr7 \ --out test_sample.vcf \ -et NO_ET \ -K my_key.key

Any ideas what could be wrong?

Thanks,
Michael Knudsen

Tagged:

Best Answer

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie
    Accepted Answer

    This is a known bug that was reported very recently, we're working on fixing it. Sorry for the inconvenience.

  • micknudsenmicknudsen DenmarkMember

    @Geraldine_VdAuwera said:
    This is a known bug that was reported very recently, we're working on fixing it. Sorry for the inconvenience.

    Thanks for your quick reply. Looks like it has already been fixed in the latest nightly build.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    The latest nightly works for you? That's great! We did have a fix in there already but we had reports that it might not work for everyone. Glad to hear you're all set.

  • micknudsenmicknudsen DenmarkMember

    @Geraldine_VdAuwera said:
    The latest nightly works for you? That's great! We did have a fix in there already but we had reports that it might not work for everyone. Glad to hear you're all set.

    Well, I have only tested in on a single chromosome from a single sample, but it worked great.

  • 2nelly2nelly SwitzerlandMember

    Dear Geraldine,

    I am facing the same problem with empty vcf after trying to create PON!
    Any guidelines?

    Thanks

  • manon_sourdeixmanon_sourdeix FranceMember

    @Geraldine_VdAuwera and @2nelly the nightly build did work for me for this specific issue !

  • TsunamiTsunami ChinaMember

    I have faced the same question. But I can't open the links to newest nightly build. Once I click the url and accept the license, the webpage would stay blank and no more changes happen. Anyone could give some advice?

  • micknudsenmicknudsen DenmarkMember

    @Tsunami said:
    I have faced the same question. But I can't open the links to newest nightly build. Once I click the url and accept the license, the webpage would stay blank and no more changes happen. Anyone could give some advice?

    Maybe a temporary error? Works fine for me right now (using Safari on Mac OS X El Capitan).

  • TsunamiTsunami ChinaMember

    @micknudsen said:

    @Tsunami said:
    I have faced the same question. But I can't open the links to newest nightly build. Once I click the url and accept the license, the webpage would stay blank and no more changes happen. Anyone could give some advice?

    Maybe a temporary error? Works fine for me right now (using Safari on Mac OS X El Capitan).

    I don't know. I've tried different browsers but that couldn't work. I also ask for others' help to try this link, no good news till now. So I really don't know how to fix it out.

  • TsunamiTsunami ChinaMember

    @micknudsen said:

    @Tsunami said:
    I have faced the same question. But I can't open the links to newest nightly build. Once I click the url and accept the license, the webpage would stay blank and no more changes happen. Anyone could give some advice?

    Maybe a temporary error? Works fine for me right now (using Safari on Mac OS X El Capitan).

    I don't know. I've tried different browsers but that couldn't work. I also ask for others' help to try this link, no good news till now. So I really don't know how to fix it out. Not sure

  • TsunamiTsunami ChinaMember

    @micknudsen said:

    @Tsunami said:
    I have faced the same question. But I can't open the links to newest nightly build. Once I click the url and accept the license, the webpage would stay blank and no more changes happen. Anyone could give some advice?

    Maybe a temporary error? Works fine for me right now (using Safari on Mac OS X El Capitan).

    OK I directly found the download links in GATK download page finally, and it worked! Thanks for your helping, I just can't believe that I didn't try this way in the past few days :(

  • TsunamiTsunami ChinaMember

    Another question. I've ran the former steps by the general version of GATK-3.5, now I need to use MuTecte2 in nightly-build. Will this make difference? Should I rerun the former by nightly-build? And how about the later analysis?

  • TsunamiTsunami ChinaMember

    @micknudsen said:

    @Tsunami said:
    I have faced the same question. But I can't open the links to newest nightly build. Once I click the url and accept the license, the webpage would stay blank and no more changes happen. Anyone could give some advice?

    Maybe a temporary error? Works fine for me right now (using Safari on Mac OS X El Capitan).

    I don't know. I've tried different browsers but that couldn't work. I also ask for others' help to try this link, no good news till now. So I really don't know how to fix it out.

  • Hi,
    I am having similar issue. I am using GenomeAnalysisTK-3.6-0. I tried using the latest nightly build. I tried applying all suggested solution, but the problem still persists.

    Any way I can get this resolved?

    Thank you.

    Example verbose when I am running the command:

    Using SSE4.1 accelerated implementation of PairHMM
    INFO 07:29:26,587 VectorLoglessPairHMM - libVectorLoglessPairHMM unpacked successfully from GATK jar file
    INFO 07:29:26,587 VectorLoglessPairHMM - Using vectorized implementation of PairHMM
    INFO 07:29:26,588 VectorLoglessPairHMM - Time spent in setup for JNI call : 0.0
    INFO 07:29:26,588 PairHMM - Total compute time in PairHMM computeLikelihoods() : 0.0
    INFO 07:29:26,589 MuTect2 - Ran local assembly on 0 active regions
    INFO 07:29:26,591 ProgressMeter - done 3.088286401E9 4.8 h 5.0 s 100.0% 4.8 h 0.0 s
    INFO 07:29:26,592 ProgressMeter - Total runtime 17112.32 secs, 285.21 min, 4.75 hours
    INFO 07:29:26,592 MicroScheduler - 67477698 reads were filtered out during the traversal out of approximately 67477698 total reads (100.00%)
    INFO 07:29:26,592 MicroScheduler - -> 0 reads (0.00% of total) failing BadCigarFilter
    INFO 07:29:26,592 MicroScheduler - -> 65707570 reads (97.38% of total) failing DuplicateReadFilter
    INFO 07:29:26,593 MicroScheduler - -> 0 reads (0.00% of total) failing FailsVendorQualityCheckFilter
    INFO 07:29:26,593 MicroScheduler - -> 0 reads (0.00% of total) failing MalformedReadFilter
    INFO 07:29:26,593 MicroScheduler - -> 1770128 reads (2.62% of total) failing MappingQualityUnavailableFilter
    INFO 07:29:26,593 MicroScheduler - -> 0 reads (0.00% of total) failing NotPrimaryAlignmentFilter
    INFO 07:29:26,594 MicroScheduler - -> 0 reads (0.00% of total) failing UnmappedReadFilter

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @Bhakti
    Hi,

    It looks like most of your reads are filtered out by the duplicate read filter. What kind of data are you working with?

    -Sheila

Sign In or Register to comment.