MuTect2 amplicon somatic calling, variants missed, -stand_emit no effect

rcorbett2rcorbett2 vancouverMember

Hi all,
I'm trying to use MuTect2 for somatic calling between matched tumour normal pairs of amplicon sequencing.

Using the default parameters there are about 10 variants that I have reasons to believe should be called but are not called with the default parameters of mutect2.

Here is my command:
java-jar GenomeAnalysisTK.jar -T MuTect2 -I:tumor tumour.bam -I:normal normal.bam -R GRCh37-lite.fa --disable_read_filter DuplicateRead

Since there were a few missed variants I tried using the -stand_emit_conf parameter across 1-10 to see if anything should change. I got the exact same calls each time. Should I be using a different parameter to tune the sensitivity of Mutect2?

thanks,
Richard

Tagged:

Best Answer

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    For the record, to answer the part of the question about the emit conf threshold, changing between values in the range of 1 to 10 will usually make very little difference. When we tune that value we usually do it in increments of 10.

    For variants that you think should be getting called, there's an article in the "Common Problems" section of the Guide that addresses this and recommends some troubleshooting tips (including generating an output bam to evaluate the role of realignment). It was written for HaplotypeCaller but most of it applies equally to MuTect2.

  • EADGEADG KielMember ✭✭✭

    @rcorbett2

    Did you try to deactivate Downsampling with -dt NONE \ command ? Most parts of GATK have it enabled by default. As I remember the default value varies between 250 and 1000 reads per position.

Sign In or Register to comment.