IndelRealigner and --downsample_to_coverage / -dcov

mikepmikep Albany, NYMember

I ran the IndelRealigner tool with this option: --downsample_to_coverage 100000. i see this output line, which leads me to believe the downsample option was recognized:
INFO 09:42:26,159 GenomeAnalysisEngine - Downsampling Settings: Method: BY_SAMPLE, Target Coverage: 100000

yet, i also see multiple lines like this in the output:
INFO 09:43:59,101 IndelRealigner - Not attempting realignment in interval gi|224589819:117115017-117313719:44370-44521 because there are too many reads.

i thought the downsampling would alleviate excluding regions where too many reads are present? i do believe the regions are being excluded because the IndelRealigner tool completes quickly, as compare to runs i've made when i've set the max to align to 100000.

to be explicit, i want all regions included in processing, and i'm willing to down sample to make this happen.

thanks for the help.

Best Answers

Answers

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @mikep
    Hi,

    I wonder if the interval it skipped has more than 100,000 reads. Instead of trying to set the downsampling threshold, can you try setting -maxInMemory to a really high number? Also, please do set -maxRead to a really high number as well.

    -Sheila

  • mikepmikep Albany, NYMember

    thanks for you prompt response.

    The regions likely do have more than 100,000 reads - or close to it. i've checked some of the regions w/ depth of coverage tool and see that coverage is in this neighborhood.

    i have already experimented with the -maxRead, setting its value to 100000. those runs ran (obviously, much slower), but i still had some regions excluded because the number of reads exceed 100000. my thought is that 100000 reads is enough and i'd like to simply downsample to that value and include all regions, rather than keep increasing -maxRead until no regions are kick out.

    so... still... any idea why specifying -dcov 100000 doesn't appear to downsample? or, how can i get Indelrealigner to down sample.

    thanks.

  • mikepmikep Albany, NYMember

    ok, thanks. that makes sense.

    it seems that i could use -dcov and -maxReads together? am i correct in thinking that if i increase the -maxReads allowed to IndelRealigner, i won't have to lower the -dcov target as much?

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Yes, that should work.

Sign In or Register to comment.