Holiday Notice:
The Frontline Support team will be offline February 18 for President's Day but will be back February 19th. Thank you for your patience as we get to all of your questions!

SplitNCigarReads ERROR stack trace

Sorry for the wrong title in last message.

Hello, I'm working on detecting RNA editing sites and follow the workflow "Calling variants in RNAseq", when I used SplitNCigarReads I encountered a "ERROR stack trace".

my command is "java -jar $GATK -T SplitNCigarReads -R $hg -I $input.bq.bam -o $input.nCigar.bam -rf ReassignOneMappingQuality -RMQF 255 -RMQT 60 -U ALLOW_N_CIGAR_READS".

and the error is:

INFO 19:25:59,816 ProgressMeter - Location | reads | elapsed | reads | completed | runtime | runtime
INFO 19:26:08,285 ReadShardBalancer$1 - Loading BAM index data
INFO 19:26:08,287 ReadShardBalancer$1 - Done loading BAM index data

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace
java.lang.NullPointerException
at htsjdk.samtools.SAMRecordCoordinateComparator.fileOrderCompare(SAMRecordCoordinateComparator.java:82)
at htsjdk.samtools.SAMRecordCoordinateComparator.compare(SAMRecordCoordinateComparator.java:43)
at org.broadinstitute.gatk.tools.walkers.rnaseq.OverhangFixingManager$SplitReadComparator.compare(OverhangFixingManager.java:350)
at org.broadinstitute.gatk.tools.walkers.rnaseq.OverhangFixingManager$SplitReadComparator.compare(OverhangFixingManager.java:341)
at java.util.PriorityQueue.siftUpUsingComparator(PriorityQueue.java:649)
at java.util.PriorityQueue.siftUp(PriorityQueue.java:627)
at java.util.PriorityQueue.offer(PriorityQueue.java:329)
at java.util.PriorityQueue.add(PriorityQueue.java:306)
at org.broadinstitute.gatk.tools.walkers.rnaseq.OverhangFixingManager.addRead(OverhangFixingManager.java:217)
at org.broadinstitute.gatk.tools.walkers.rnaseq.SplitNCigarReads.splitNCigarRead(SplitNCigarReads.java:233)
at org.broadinstitute.gatk.tools.walkers.rnaseq.SplitNCigarReads.reduce(SplitNCigarReads.java:210)
at org.broadinstitute.gatk.tools.walkers.rnaseq.SplitNCigarReads.reduce(SplitNCigarReads.java:118)
at org.broadinstitute.gatk.engine.traversals.TraverseReadsNano$TraverseReadsReduce.apply(TraverseReadsNano.java:251)
at org.broadinstitute.gatk.engine.traversals.TraverseReadsNano$TraverseReadsReduce.apply(TraverseReadsNano.java:240)
at org.broadinstitute.gatk.utils.nanoScheduler.NanoScheduler.executeSingleThreaded(NanoScheduler.java:279)
at org.broadinstitute.gatk.utils.nanoScheduler.NanoScheduler.execute(NanoScheduler.java:245)
at org.broadinstitute.gatk.engine.traversals.TraverseReadsNano.traverse(TraverseReadsNano.java:102)
at org.broadinstitute.gatk.engine.traversals.TraverseReadsNano.traverse(TraverseReadsNano.java:56)
at org.broadinstitute.gatk.engine.executive.LinearMicroScheduler.execute(LinearMicroScheduler.java:108)
at org.broadinstitute.gatk.engine.GenomeAnalysisEngine.execute(GenomeAnalysisEngine.java:315)
at org.broadinstitute.gatk.engine.CommandLineExecutable.execute(CommandLineExecutable.java:121)
at org.broadinstitute.gatk.utils.commandline.CommandLineProgram.start(CommandLineProgram.java:248)
at org.broadinstitute.gatk.utils.commandline.CommandLineProgram.start(CommandLineProgram.java:155)
at org.broadinstitute.gatk.engine.CommandLineGATK.main(CommandLineGATK.java:106)

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 3.4-46-gbc02625):
ERROR
ERROR This might be a bug. Please check the documentation guide to see if this is a known problem.
ERROR If not, please post the error message, with stack trace, to the GATK forum.
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions http://www.broadinstitute.org/gatk
ERROR
ERROR MESSAGE: Code exception (see stack trace for error itself)
ERROR ------------------------------------------------------------------------------------------
my input bam file is about 3Gb, I think it's big enough. Could you please help me ? Or whether I can skip this command by using ""java -Xmx8g -jar $GATK -R $hg -T RealignerTargetCreator -o $input.realn.intervals -I $input.bq.bam -U ALLOW_N_CIGAR_READS"?

Many thanks for any help.

Answers

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @Angelven
    Hi,

    What version of GATK are you using? Can you try adding -fixNDN to your command?

    -Sheila

  • Thanks for your response. My GATK is the latest version: 3.4-46-gbc02625, I have tried to add -fixNDN to my command, but the same ERROR occured. @Sheila

  • Also, I have tried your latest nightly build: GenomeAnalysisTK-nightly-2015-09-29-g1e9a84f, but also come the same ERROR.

  • By the way, I have tried the command "RealignerTargetCreator" using the same input and reference file, just like "java -Xmx8g -jar $GATK -R $hg -T RealignerTargetCreator -o $input.realn.intervals -I $input.bq.bam -U ALLOW_N_CIGAR_READS", it runs well, so it seems my reference file and input bam.file and their index are all right ?

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @Angelven
    Hi,

    Are you using -nt or -nct? Can you try running without them? If that does not work, I will need you to upload a bug report.

    Thanks,
    Sheila

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Also, have you run Picard ValidateSamFile to validate the bam?

  • AngelvenAngelven Member

    I have viewed my bam.file carefully and test a lot, here I fetch ~1000 reads containing the error-causing read:

    "ST-E00192:81:H3VH7CCXX:2:1115:21574:42728  87  chr1    9877171 37  83M1772N50M1256N12M1I4M =   48  -257    ATGTCCGAGCATTCCTTCAAATGGACAGCCCAAGACATCAGTCAGATCCATCTGAAGATGAGGATGAAAGAAGTACTTCGAAGCCACATTCTACCTCACGGAACATCAACCTGGGACCAACTGGAAATCCTCATGCTAAACCAACTGGAA  AFKFFFKFKKKKKKKKFFFFKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKFKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKAKFFFAA  X0:i:1  X1:i:0  MD:Z:145A3  RG:Z:d2KO   XG:i:1  AM:i:0  NM:i:2  SM:i:37 XM:i:1  XO:i:1  XT:A:U"
    

    When I deleted this read, it run well, otherwise error. My RNA-seq bam.file is about 3Gb and may contain lots of such error-causing reads, so could you let me know how to fix such problem? BTW, I have uploaded a bug report "20151004_bug_report_Angelven", in that file, I generated two snippet bam.files, one for error and another is well running.
    Many thanks.

  • AngelvenAngelven Member

    In my command, I did not use -nt or -nct. @Sheila And I have run ValidataSamFile to validate the bam, it reported lots of same type errors like:
    ERROR: Record 352, Read name ST-E00192:81:H3VH7CCXX:2:2220:30171:48371, Mate alignment does not match alignment start of mate
    ERROR: Record 352, Read name ST-E00192:81:H3VH7CCXX:2:2220:30171:48371, Mate reference index (MRNM) does not match reference index of mate
    These reads all come from SpliceJunction-mapping reads and it seems to have little influence in running SplitNCigarReads, I'm not sure if my opinion was reasonable or could you give me some tips? @Geraldine_VdAuwera .

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @Angelven
    Hi,

    Sorry for the late response. Can you try running with the latest nightly build? I think this may have been fixed in a recent nightly build. https://www.broadinstitute.org/gatk/download/nightly

    Thanks,
    Sheila

Sign In or Register to comment.