To celebrate the release of GATK 4.0, we are giving away free credits for running the GATK4 Best Practices pipelines in FireCloud, our secure online analysis portal. It’s first come first serve, so sign up now to claim your free credits worth $250. Sponsored by Google Cloud. Learn more at

Specifying jobRunner memory allocation


I am trying to use GATK Queue to submit scatter-gather jobs on our local cluster. However, the jobs almost always run out of memory, because only 1GB is allocated by default. I run Queue with the

-jobRunner Drmaa

option, and I have tried all different combinations of

-memLimit 8
-resMemLimit 8
-resMemReq 8

to see if I could somehow force it to allocate more, but the problem persists.

Any ideas how to increase the memory allocation? Our cluster uses SLURM for job submission.

Best Answer


Sign In or Register to comment.