Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.
Attention:
We will be out of the office on November 11th and 13th 2019, due to the U.S. holiday(Veteran's day) and due to a team event(Nov 13th). We will return to monitoring the GATK forum on November 12th and 14th respectively. Thank you for your patience.

Filter in DepthOfCoverage 3.3-0

HerderHerder NetherlandsMember

Hello GATK,

We've been using the DepthOfCoverage tool in our pipeline and noticed that the =>Q30 score per gene provided by GATK is significantly different than the =>Q30 score we calculate ourselves without any filters. On your manual page for DOC, you mention using several filters (although it isn't specified if this applies to all versions of GATK or just the last one):
NotPrimaryAlignmentFilter
FailsVendorQualityCheckFilter
DuplicateReadFilter
UnmappedReadFilter
MalformedReadFilter
BadCigarFilter

In your general manual page, you mention there is a parameter for disabling filter (--disable_read_filter, -drf). This doesn't seem to be implemented yet in 3.3-0, seeing as I get an error that the argument isn't defined and the argument isn't showing up in the help page either. Is there another way to disable filters in 3.3-0?

Kind regards,
Mark

Tagged:

Answers

  • SheilaSheila Broad InstituteMember, Broadie admin

    @Herder
    Hi Mark,

    Can you post the exact command you ran and the exact log output with the error?

    Thanks,
    Sheila

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    The --disable_read_filter functionality is only enabled for a subset of read filters (at the moment, just DuplicateReadFilter). This is done by design as the other filters are all necessary for the smooth operation of the tools. If you want to do an apples-to-apples comparison you can run PrintReads with the same filters to generate a file that you can use for your calculations.

Sign In or Register to comment.